1
$\begingroup$

I have a rendering problem, the face of one of my characters appears in a wrong place (the empty's one) as I render the image (clicking F12). When I just switch to the rendered mode in the 3D view everything works perfectly.

I attach a screenshot of the rendered image.

enter image description here

$\endgroup$
5
  • $\begingroup$ Just in case if you need further information: I'm working in Cycles Render and this bug happens both in CPU and GPU Device options. $\endgroup$
    – theguest
    Commented Jul 16, 2015 at 16:41
  • 3
    $\begingroup$ What modifiers are you using? Must be something with the Viewport button on but Render button off. $\endgroup$ Commented Jul 16, 2015 at 16:44
  • $\begingroup$ Can you post screenshots of the modifier stack for the character (is it all one mesh?), and of the outliner? Is the head a separate mesh object? Perhaps the armature mod for the head doesn't have the Render button enabled? $\endgroup$ Commented Jul 16, 2015 at 16:48
  • $\begingroup$ Yes, the problem was that there was a render button off in the modifier stack. So, now it's solved. Thank you! $\endgroup$
    – theguest
    Commented Jul 17, 2015 at 8:43
  • $\begingroup$ Okay, good, I've posted my official answer. Can you confirm if it was the armature modifier? $\endgroup$ Commented Jul 17, 2015 at 13:01

3 Answers 3

2
$\begingroup$

You likely have a modifier on the head object, most likely an armature modifier that has the Render setting off. Enabling the render button on the modifier will solve the issue.

$\endgroup$
1
  • $\begingroup$ Wow, I had a similar problem, and it was driving me nuts for days! I’m a Blender noob, so I didn’t even know what to search for, until I stumbled upon this. Thanks for clearing it up! :D $\endgroup$ Commented Mar 26, 2020 at 2:51
2
$\begingroup$

A similar issue could occur when the dislocated object has some animation keyframes set in place. Forcing the object to snap to it's 'animated' position whenever you're rendering that specific frame.

$\endgroup$
1
  • $\begingroup$ This fixed my issue. Disabled animations render looked right again. Thank you! $\endgroup$
    – Ray Lee
    Commented May 2 at 6:58
1
$\begingroup$

My first hunch, in the abscense of a ~.blend file, is that the head and the body are separate objects, and that at some point you moved the head in edit mode when you should have moved the head in object mode. Moving the head in edit mode moves the vertices, but not the object's origin, but the object is rendered based on the objects origin. The solution (assuming the origin is in the proper place) is to select edit mode, if you're not already in that mode, select the head object and press the key combination CTRL - ALT - SHFT - C, and select the option "geometry to origin". If the origin is not in the right point, you'll want to move the origin to where it is, before moving the geometry to the origin. After you have the origin and the geometry in the proper location relative to where you want them, you'll enter object mode and apply the location using the combination CTRL - A.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .