0
$\begingroup$

This is what I made, multiple boxes (the default box), default camera and lamps.

viewport

And when I render, it looks like this:

render

Correct me if I'm wrong, but shouldn't I see the different boxes? Is it normal that the shadows are so dark that they hide all edges?

$\endgroup$
  • $\begingroup$ Add more lamps... $\endgroup$ – someonewithpc Jul 16 '15 at 14:27
  • $\begingroup$ You only have 2 lamps, the sides of the cubes that are rendering black have nothing to illuminate them. $\endgroup$ – PGmath Jul 16 '15 at 14:34
  • 1
    $\begingroup$ Also render could be too dark without global illumination (secondary light bounces). $\endgroup$ – Daniil Romanov Jul 16 '15 at 15:18
2
$\begingroup$

The problem is that you don't have enough lamps at the right positions (as said in the comments by someonewithpc and PGmath). You can fix this in various ways:

  1. Just keep adding/duplicating more point lamps, and spread them around.
  2. Keep only one lamp, and set its mode to Sun.
  3. Have two lamps, one of them a Sun lamp (like in #2), and the other one a Hemi light. Then set the energy of the hemi light to ~0.2, and the energy of the sun light to ~0.8. That way you will illuminate all the faces (so no pure black), and will have shadows. (Note: If you add lights from the 'Create' menu, then you will have no shadows by default. Enable them by scrolling down, and selecting 'Ray Shadow' (only present on the Sun light))

Image

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.