5
$\begingroup$

This is my Minecraft Animation. It is made in Blender Internal and is intended to be rendered in Blender Internal. The animation consists of me running infront of Minecraft trees. These trees are mapped with UV textures of Minecraft Leaves with alpha turned on so that the leaves are transparent in places. The Animation starts at frame 8 and ends at 40. This is not a case Z fighting.

However when I render the animation I get square alpha (sometimes black pixel) artefacts in the render. Every frame has diffrent result but still has the artefacts. This is what it looks like. The white is the alpha. Open in a new tab for closer inspection.

As I said some frames have this problem and some don't

enter image description here

This one has AA disabled. This makes the alpha only one pixel each. (Open in new tab to see individual pixels) enter image description here

This problem does not occur in the rendered mode viewport. enter image description here

Leaves' Material Settings

enter image description here enter image description here

Leaves' Texture Settings

enter image description here enter image description here

Edit: I decided to restrict the leaves from render and this is the result I have. Pretty ugly. Also added, glare and vector nodes just fyi.

enter image description here

I then decided to remove the wood as well and now this happened.

enter image description here

And now there's black and alpha.

enter image description here

Here is a link to a video showing the problem.

What is going on here! Is this blend file corrupted? Please if you know the answer or what causes this please mention this down below.

And because you asked here a stripped down version of the file: https://www.dropbox.com/s/4q5qfsmjv7umtbh/Stripped%20Down.blend?dl=0

$\endgroup$
  • $\begingroup$ It might be Z fighting. Is it possible you have duplicates of the trees which are only visible in the render? $\endgroup$ – gandalf3 Jul 16 '15 at 8:56
  • $\begingroup$ No sir. I thought it could be that as well but nope. Editing the question to add another screenshot. $\endgroup$ – SkeleCrafter Jul 16 '15 at 9:07
  • $\begingroup$ Is it possible you could upload a .blend which demonstrates this behavior? $\endgroup$ – gandalf3 Jul 16 '15 at 9:33
  • $\begingroup$ @gandalf3 I already mentioned up their that I could not as my internet connection speed would take a long time to upload the file. $\endgroup$ – SkeleCrafter Jul 16 '15 at 9:38
  • 3
    $\begingroup$ Well can you shrink down the file in size? Leave only 1 tree there to showcase the behavior with only couple of textures packed? The file should be small enough then $\endgroup$ – Jaroslav Jerryno Novotny Jul 16 '15 at 9:59
7
$\begingroup$

The artifacts are not from z-fighting, but from transparent auto shadows bias.

Just turn the option off:

  • Shadow auto bias on:

    enter image description here

  • Shadow auto bias off:

    enter image description here


Elaboration:

There was once bug which was (supposedly) fixed for 2.68:

Found the cause of the problem, it's due to the ray bias options that tries to avoid bad ray traced shadows.

It's supposed to eliminate shadow artifacts on smooth shaded surfaces where the shadow terminator is - like this one (I think..):

enter image description here

My guess is that blender sometimes fails to get it automatically right, setting it to fix value then works better.

Or making the surface flat shaded should work also.

$\endgroup$
  • $\begingroup$ Thanks so much :D Well that's the last time I use the Blender Mineways Python script. Thanks. $\endgroup$ – SkeleCrafter Jul 17 '15 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.