1
$\begingroup$

I'm on an iMac using an Apple wireless keyboard and a Magic Mouse. I'm trying to remap buttons so that I can Move the 3D view left, right, up, and down with Shift Command Click&Drag. This is what I tried to customize in the Input tab of User Preferences:

enter image description here

That doesn't work, even though I managed to remap zooming with Shift Click&Drag pretty much the same way:

enter image description here

What am I doing wrong?

$\endgroup$
  • $\begingroup$ I haven't used a mac for a few years but I expect you may have a system action getting the event before blender and not passing it on. Using xfce4 Cmd+middle mouse = send window to the back. Similarly F12 is (was?) used on osx and needs to be cleared in system preferences for blender to use it. Either find what is using it and adjust the system settings or choose another combination. $\endgroup$ – sambler Jul 16 '15 at 5:03
  • $\begingroup$ @sambler Thanks for your reply. To my knowledge, the only mouse-related actions on Mac are "Hot Corners", which I'm not using. $\endgroup$ – Aubrie Jul 19 '15 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.