0
$\begingroup$

I've been following a tutorial by Daniel Kreuter on Youtube (https://www.youtube.com/watch?v=wdsY4BtlcpQ), modelling a body using a mirrored surface. I thought I had followed his actions fairly accurately, but I'm getting a weird seam on the mirrored plane in my model when I apply a multiresolution subdivide. Oddly enough, it doesn't appear when I use the subdivision surface modifier.

visible seam on mirror plane

I'm not really sure where to start looking for problems. This question has an "answer" which seams (see what I did there?) to have the same problem I'm having, with no solution. This forum post looks like they have the same problem. One of their suggestions is to move the mirror modifier above the subdivide, as the modifiers are applied sequentially. Unfortunately, that gives me the error "Cannot move a modifier requiring original data". The other suggested fixes, checking clipping (it was already checked) and increasing the merge limit, haven't worked.

Another thing I've checked, based on what I've seen on the web, is whether faces have been inserted along the mirror plane by accident. Sadly, that's not the solution either, nor is it due to duplicated vertices. What should I try next?

$\endgroup$
  • $\begingroup$ Clipping's on in the mirror already. Thanks for the normals catch. I noticed it as well when I went to sculp something and everything seemed to do the opposite of what I expected. $\endgroup$ – Jason_L_Bens Jul 15 '15 at 8:28
  • $\begingroup$ Also, please post a .blend it's easier to diagnose that way $\endgroup$ – someonewithpc Jul 15 '15 at 8:31
  • $\begingroup$ Well, I tracked down where I differed from the tutorial. Looks like he applied the mirror modifier for good before creating the multires subdivide. That explains the difference. Unfortunately, my .blend has been overwritten, so I have nothing to post up here aside from a model without the crease. $\endgroup$ – Jason_L_Bens Jul 16 '15 at 7:07
1
$\begingroup$

First I presumed that you did mirroring by negative scale around YZ-plane, then you have flipped normals at second half. But then I noticed modifier, so I was wrong.

I noticed similar result if Subdivision modifier placed higher than Mirror. Also Blender prevents from moving Multiresolution with subdivisions under Mirror, saying "Cannot move beyond non-deforming modifier" or "Cannot move above modifier requiring original data" for moving Mirror up.

I think it's a way Blender modifiers works with mesh data. I took a peek in official docs and found this: https://www.blender.org/manual/modifiers/the_stack.html - according to official info modifiers applied in order from highest to lowest. When I tried to apply them in this order, I also get seam in final mesh with both modifiers, but it was just crease in geometry, vertices are wielded, normals are outside, just little wrong geometry. Old edge at section at half-mesh left unsmoothed by modifier, because it processed differently areas where edges belong to just one face.

$\endgroup$
0
$\begingroup$

This is a common problem with the mirror modifier. Make sure you have "merge" selected in your modifiers settings.

You can also adjust the merge limit, to merge vertices more tolerantly

enter image description here

$\endgroup$
  • $\begingroup$ In this case, merge is already selected. Aside from clipping being selected as well, I match your settings. $\endgroup$ – Jason_L_Bens Jul 16 '15 at 7:09
  • $\begingroup$ @jason_L_Bens I also see, that you have you modifiers in the wrong order. Try to put the mirror-modifier on the top and add the subdivisions, after that. $\endgroup$ – Marten Zander Jul 16 '15 at 8:03
  • $\begingroup$ Unfortunately, trying to move the mirror modifier on top gives me the error "Cannot move a modifier requiring original data". $\endgroup$ – Jason_L_Bens Jul 16 '15 at 15:15
0
$\begingroup$

If you delete the middle face ( generated by the seam) and you apply multires, it works correctly. I know this is an old post, but if help someone i'm happy!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.