0
$\begingroup$

I have Blender 2.75 and I am working on a project. I want to import a transparent window texture but when I do this happens:

untransparent

It doesn't look transparent in Blender. When I render it with a light and a green cube behind it this happens:

untransparent background

The bars are transparent but the background turned black. The same thing happens with another texture when I import it. The background of the texture is white and doesn't blend in with the brick texture:

cage

How do I make these textures transparent the right way?

EDIT: When I add this node setup:

node setup

The 3rd texture (with the background not blending in) just shows all white and it's a black border when rendered.

white texture

$\endgroup$
  • $\begingroup$ What is your node setup for the bars? $\endgroup$ – PGmath Jul 13 '15 at 23:22
  • 1
    $\begingroup$ I think you do not have any alpha information in your black and white images. Try simple plugging the color socket in to the Fac of the mix node. $\endgroup$ – David Jul 14 '15 at 2:42
3
$\begingroup$

There is no alpha channel behind the bars, just around the window.

This image shows the alpha channel you have on your image. To make it transparent use the following node setup:

enter image description here

To make the black areas of the images transparent you need to edit the image on an image editor (like photoshop or gimp), or add acolor ramp to control the transparency on a new mix shader.

enter image description here

$\endgroup$
0
$\begingroup$

In cycles the proper way to use a texture with transparency is to mix a diffuse shader (or whatever shader[s] you are using for your material) with a transparent shader based on the alpha output of the image texture node.

enter image description here

$\endgroup$
  • $\begingroup$ @KalebProvost What does your node setup look like? $\endgroup$ – PGmath Jul 14 '15 at 0:10
  • $\begingroup$ The 3rd picture texture (with the background not blending in) doesn't show when I use the node settings. $\endgroup$ – Kaleb Provost Jul 14 '15 at 0:13
  • $\begingroup$ @KalebProvost It's kind of hard to tell exactly what you're doing wrong without seeing a few more details of what you are doing. Would it be possible to post some more screenshots or upload your .blend to Blend-Exchange? $\endgroup$ – PGmath Jul 14 '15 at 0:16
  • $\begingroup$ I edited the question to include my node setup. It works for the bars but not the last texture. $\endgroup$ – Kaleb Provost Jul 14 '15 at 0:22
  • 1
    $\begingroup$ @KalebProvost Does the bars texture have an alpha texture? $\endgroup$ – PGmath Jul 14 '15 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.