1
$\begingroup$

I am noticing quite some jaggy edges in my renders. I don't see AA options when using Cycles. Increasing the samples only seems to reduce noise. The images show the problem areas marked. They are using different sample settings, but the edges are exactly the same. You might have to download and zoom in to see better. With "samples" i am referring to the samples in the properties window of the render tab (properties->render->sampling). First picture was using 24 with "square samples" checked, second one was using 300 samples.

Sampling24

Sampling300

Here is a zoomed version, 200%

enter image description here

$\endgroup$
3
  • $\begingroup$ The second image shows 300 samples without "square samples" ticked. And as mentioned, the jaggies are the same. Pity that there is no extra setting for AA strenght. But i will try a differernt sample pattern, good idea! $\endgroup$ Commented Jul 13, 2015 at 15:35
  • $\begingroup$ I tried correlated multi-jitter. Its different, but no improvement. $\endgroup$ Commented Jul 13, 2015 at 15:49
  • $\begingroup$ I thought maybe mis-using the compositor for AA. So setting the render output resolution to twice what you need, then add a transform node in the compositor before file output and setting it to scale down to 50%. The transform node also has a filtering option. Cumbersome, but basically thats what AA would do. $\endgroup$ Commented Jul 13, 2015 at 15:58

3 Answers 3

2
$\begingroup$

If you switch to branched path tracing you can access and alter the Anti Alias sampling. enter image description here

$\endgroup$
1
  • $\begingroup$ This has taken care of it actually. Its just strange that this option is only available when using branched path tracing. $\endgroup$ Commented Jul 16, 2015 at 21:07
2
$\begingroup$

Here's an example of a similar problem I'm facing at the moment.

enter image description here

Here the ribbed feature of the can happens to be on the boundary of pixels for every rib, this means cycles won't know which colour to make most important (that would require spatial antialiasing), it doesn't have contextual information that our brains have. This is the Moiré effect, it almost looks transparent.

But if I zoom in and render just the can at higher resolution it's obvious that the geometry is fine.

enter image description here

I may be wrong, but I think this is an edge case which directly relates the feature size being so close to pixels and that causes the jaggie pattern to emerge. As for extra AA, cycles does AA implicitly I think it's part of the algorithm, if it's getting it wrong there's little that can be done (without changing the geometry a little)

This may seem like a lazy answer, but it's normal to render at higher resolution than the final needed render, and sample down in post-processing to help the AA. In the case where you have features which are about the same size as a pixel (or in a pattern of every 2nd pixel), this becomes important. It's easier to sample down once you have all the right pixels than it is for Cycles to perform AA with insufficient information.

Other helpful ways to reduce jaggies are:

  • bevels to make the surface edges less abrupt (help guide the light)
    • but make sure the bevels are finer grained than the pixels used to represent them, so go for a multi-cut fillet if you can spare the geometry.
  • add imperfections (most surfaces are not flawless..it all contributes to realism and helps break up unwanted patterns)
  • softer lighting, more bounces.
  • The post processing tab has a Dither option to help avoid banding, worth seeing if that tames the effect a bit.
  • reduce the glossyness, or specular effect, it will be most noticable at the corners. that means the difference between: enter image description here and
    enter image description here
$\endgroup$
1
  • $\begingroup$ Well, the way i understand AA is, that the renderer internally renders at a higher resolution (for example 4 times if AA is set to 2x2) and then scales down for final output. So while you are right that Cycles couldn't perform AA due to insufficient information, it could do so if it was possible to tell him to render at higher res internally by some AA setting. $\endgroup$ Commented Jul 13, 2015 at 15:23
1
$\begingroup$

We have pixel filter size with gaussian filtering (default) in render properties, film tab.

enter image description here

$\endgroup$
4
  • $\begingroup$ I tested this, but it made the image just more blurry. No increase in AA quality. $\endgroup$ Commented Jul 16, 2015 at 21:08
  • $\begingroup$ Sorry it didn't help you. I don't know a lot about pixel filters, but I remember reading about aa issues when there is a lot of contrast, like in your image. Maybe it would help if you set "Clamp Direct" in render properties, sampling tab. Try setting it just low enough to not lose brilliance, but toning down highlights enough so that antialiasing has an easier job. $\endgroup$
    – Sanne
    Commented Jul 17, 2015 at 14:42
  • $\begingroup$ I just tested, it definitely helps. You can check how high the RGB values are by clicking on the image in the render window. At the bottom will be RGB value display of the sampled point. In my case I had values higher than 3. When i set clamp Direct to 2 or even as low as 1, aa at such a high contrast edge is greatly improved. $\endgroup$
    – Sanne
    Commented Jul 17, 2015 at 15:05
  • $\begingroup$ I generally don't like clamping, as it means loosing image information. But its good to keep in mind for extreme cases. $\endgroup$ Commented Jul 18, 2015 at 10:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .