2
$\begingroup$

I've set up a particle system that needs to have exactly one particle emitted from each face on the emitter mesh. However, the "Particles/Face" setting is apparently not working. When it's set low there are many faces not emitting particles, yet when it's set high enough that no faces are without particles there are also many doubled-up particles overlapping.

The particles are bricks, so they are not animated, but I don't want holes in the wall or doubled-up geometry. Is there a problem with the "Particles/Face" setting, or am I misunderstanding what it does? How can I get just one particle per face?

$\endgroup$
1
$\begingroup$

You could emit the bricks from vertices, make sure that you emit exactly the same number of particles as the emitting mesh has vertices (121 in this case):

enter image description here

  • from verts

Emitting from faces with the grid option selected creates a box of emitted particles.

enter image description here

  • from faces
$\endgroup$
  • $\begingroup$ Thanks! Emitting from vertices worked for me. I found that at some vert counts one brick would be missing from its proper place and instead overlapping somewhere else. If I upped the particle count to just one more, the hole got filled. There would still be one extra brick overlapping somewhere but that's much more acceptable in a render than a missing brick. $\endgroup$ – Mentalist Jul 12 '15 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.