0
$\begingroup$

After watching this tutorial on setting up network renders, I set about trying to make one myself. However, regardless of what file type I have selected, it keeps outputting black .exr files.

I viewed a variety of links (tutorial, tutorial, problem post, very similar StackExchange post with no answer, unanswered YouTube comments reporting the same problem, and a post about compositing .exr s.) However, I still am not sure what I'm doing wrong.

Here's a link to the output and the file.

Know I didn't write a lot, so please feel free to ask questions. Any help is appreciated.

$\endgroup$
  • 1
    $\begingroup$ Personally I've never had much success with the net render addon. Instead I've used this approach (also see blender.stackexchange.com/q/15844/599 and my answer on the first SE question you linked). $\endgroup$ – gandalf3 Jul 12 '15 at 7:36
  • $\begingroup$ @gandalf3 Hmm... well, I'll give that a go in the mean time. However, it'd be really nice if I could get it to work. $\endgroup$ – JMY1000 Jul 12 '15 at 17:53
  • 2
    $\begingroup$ You may be interested in flamenco $\endgroup$ – sambler Jul 13 '15 at 6:06
  • 1
    $\begingroup$ What are you opening your exrs with? Have you tried opening your exr's in blenders uv/image editor? The images you have in your google drive above look right to me - I have opened a few files from both job1 and job2 $\endgroup$ – sambler Jul 13 '15 at 6:59
  • $\begingroup$ @sambler GIMP and Preview. Will try that. $\endgroup$ – JMY1000 Jul 14 '15 at 7:01
2
$\begingroup$

While multilayer OpenEXR files are a useful way to keep all the render results in one file, not every application supports them.

An easy way to get render output that can be used outside of blenders compositor is to save each part into a more compatible file, blenders file output node is useful for this.

enter image description here

As shown in the node properties, each output file can have it's own file format and any compositing can be included with the output.

$\endgroup$
  • $\begingroup$ Okay, I'll give this a crack. $\endgroup$ – JMY1000 Jul 16 '15 at 19:11
  • $\begingroup$ Couldn't get that to work. Still does OpenEXR files, even when I told it to use png. i.imgur.com/HCJS3dh.png is my setup. $\endgroup$ – JMY1000 Aug 16 '15 at 17:43
  • $\begingroup$ Check you have enabled 'use nodes' in the node window and compositing under post processing in render settings. $\endgroup$ – sambler Aug 17 '15 at 10:30
  • $\begingroup$ Both boxes checked, still nothing. $\endgroup$ – JMY1000 Aug 18 '15 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.