0
$\begingroup$

Yesterday I installed Blender 2.75 on my Lenovo X230 with Intel graphics HD 4000.

Since the beginning I have been unable to select vertices in edit mode by clicking. Also the loop cut doesn't work at all (Ctrl+R, there is no purple outline and nothing happens after clicking).

I've got a friend who has some tens of hours spent in blender and he is also unable to do that on my pc. On his, however, it works like charm...

I also had some trouble with glitches in the gui, but it got solved by setting window draw method to triple buffering - indicating that intel HD drivers might be an issue.

I read about updating my drivers and that's what I did but was only able to update Intel hd graphics to version 9.18.10.3359 from 15.11.2013. Then, even if trying to update manually, my Windows 7 professional says it's up to date.

Any idea how to solve this?

$\endgroup$
  • 3
    $\begingroup$ not to discourage you, but if blender does not work there is no guarantee that any other 3D software will work. It does sound like a problem with some setting in the graphics. $\endgroup$ – David Jul 11 '15 at 15:00
  • $\begingroup$ possibly this answer to a similar UI related question might help: blender.stackexchange.com/a/32111/47 $\endgroup$ – zeffii Jul 11 '15 at 15:55
  • $\begingroup$ I tried what you suggested @zeffii , but it didn't help. Meanwhile I installed 3ds max and tried some basic tutorial and everything seems to work all right in there, so it seems to be a driver problem specific to blender. But I still would like to work with blender rather than 3DS max... $\endgroup$ – lazy_traveller Jul 11 '15 at 17:48
  • $\begingroup$ Do you use a 3-button mouse and are you sure that you used the right mouse button for selection? (This is different to almost all known software that selection works with RMB). I don't think that this is related to your graphics driver. $\endgroup$ – stacker Jul 11 '15 at 18:06
  • $\begingroup$ Are you sure that you have the most up to date Intel drivers? :) $\endgroup$ – Hexbob6 Jul 11 '15 at 22:29
2
$\begingroup$

Lazy_traveller, you omitted a crucial bit of information when you asked your question. That crucial bit is the word, "notebook", which you didn't mention until your reply to Hexbob6. There are settings in the user preferences to make use of a laptop possible, but personally, I don't find them very satisfactory. Based upon my own experience, I would most emphatically suggest getting an external full sized keyboard—the kind with a separate numeric keypad—and a 3 button mouse. You should be able to get both for about USD 25.00 (or up, if you're so inclined) in the US. I have both a USB keyboard, and a USB mouse, but I don't know of any reason, if you wanted, that you could not use a bluetooth keyboard or mouse. It works like a charm. If your keyboard and mouse come with separate drivers, I would be sure to make sure they are the latest versons.

As to CTRL-R on your computer not activating loop-cut in Blender, I suspect (don't know for certain, as I don't have a Lenovo Laptop) that the culprit here is that on your laptop, the key combination CTRL-R is being used to control some aspect of the hardware, so the keystroke is being filtered out, and never sent on to Blender.

If you really want to (or must, for whatever reasons) use your notebook with Blender, do a Google search for "using Blender on a laptop", find the most recent tutorial, and adjust the user preferences as indicated in the tutorial. It is even possible to bind loop-cuts to a different key combination than CTRL-R, if necessary.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.