4
$\begingroup$

The Issue

Is there any way to speed up the preview of image strips in the video sequence editor? Unfortunately, the preview in the VSE is very choppy and indicates that it runs at only a few frames per second. Even worse, the preview starts to lag compared to the music strip (although “AV-sync” is turned on) which makes it very difficult to cut on beats.

What I’ve tried

At first I thought the slowness would be due to transform effects on the images; I have many images on which I’m applying a Ken Burns Effect. But it’s also slow on plain image strips (with no effects on them).

I have already tried to add proxies to the image strips but that didn’t have any noticeable effect.

Reducing the image resolution might be an option, however, I need the additional pixels for the mentioned zoom effects.

Some more Background

My images are not unusually big, I’d say: just 1–3 MB each with about 7–10 megapixels.

I’ve tested this on both Blender 2.74 and on the latest 2.75a version – each running on Ubuntu 14.04 64bit with 8 GB of RAM. I have an older ATI video card, so I can’t use video acceleration.

$\endgroup$
  • $\begingroup$ What is the image format you use? JPG, PNG, ... ? And, after having built proxies, did you choose the corresponding render resolution in the preview window's properties panel ? $\endgroup$ – Polosson Jul 11 '15 at 19:14
  • $\begingroup$ I’m using JPG images. Yes, the proxy render size in the scene preview is set to the same as the size of the built proxies (25%). $\endgroup$ – Chriki Jul 12 '15 at 8:52
2
$\begingroup$

You could increase the memory cache (1GB by default) to your available physical memory and increase the number of prefetch frames.

This is done in Menu: File / User Preferences in the System-tab. Ctrl-Alt-U

enter image description here

$\endgroup$
  • $\begingroup$ Thanks, this seems to somewhat help in combination with proxies: after viewing a certain part of my video several times, the frame rate goes up to 24 fps. Even if I come back to the same part of the video later, it is often still at 24 fps. However, I wonder why (proxied) videos run at 24 fps right after starting Blender while (proxied) images always need several playback cycles before they run at 24 fps … $\endgroup$ – Chriki Jul 12 '15 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.