1
$\begingroup$

I'm a beginner in Blender - i have a problem with mysterious shades in flat surface. Model comes from SketchUp (exported to OBJ / imported to Blender).

Model is composed of blocks, shades are near block's edges (but only on some of them). My idea was Sketchup model have some smooth edges, but it haven't...

Any idea what is the problem??

Thank you very much in advance!

Blender material shading | rendered shading (uncomplete) | SketchUp model

EDIT full resolution preview: http://lukex.name/temp/preview.png

$\endgroup$
  • 1
    $\begingroup$ remove doubles and recalculate the normals $\endgroup$ – Chebhou Jul 9 '15 at 20:53
  • 1
    $\begingroup$ If you look at the topology in those places I'm guessing they are caused by long tris and ngons. See if flat shading (3D view > Tool Shelf (T) > Tools > Shading) and recalculating the normals helps (Ctrl+N in Edit mode). $\endgroup$ – gandalf3 Jul 9 '15 at 20:57
  • $\begingroup$ I had the same problem. All the objects look as if their faces were set to smooth. I solved the problem by setting flat AND giving a look to "Autosmooth" "checkbox in Normal" panel under "Object data" tab (I had to un-ceck them all). By seeing your screenshots only I would say that you may suffer of the same problem...give it a try $\endgroup$ – Carlo Jul 14 '15 at 21:10
  • $\begingroup$ SketchUp exports horrible geometry to .obj. I didn't ever come across one that I haven't had to fix. Normals and doubles are usually the most common, thats very true. $\endgroup$ – Jaroslav Jerryno Novotny Aug 14 '15 at 15:30
1
$\begingroup$

Thank you very much for your comments. Later i was solving how to import model by separate floors and it gives me a spoiler to solve this.

The problem causes import options and complicacy of model:

In Blender OBJ import options unchecking Smooth Groups and no Split by helped (in case of shadows on simple blocks //Groups in SketchUp had one surface identical and Smooth Groups in blender causes this problems).

Next - SketchUp allows making very complicated surfaces (many edge lines, only one surface [i used it for floor // it isn't showed in pictures]). But OBJ exporter probably has problem to divide it to triangles. It causes overcasting triangles and same shadows in flat surface. Dividing very complicated surfaces (in Sketchup by line tool) helped.

Good luck in rendering ;-)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.