1
$\begingroup$

I'm running Blender on windows. Recently I tried to use GPU rendering with my AMD R9 290, but upon rendering, I get an error reading "OpenCL build failed: error in console."

Meanwhile, in the console:

Device init success
Compiling OpenCL kernel ...
Build flags:
OpenCL kernel build output:
Error:E013:Insufficient Private Resources

OpenCL build failed: errors in console

CPU rendering works fine.

I'm running Windows 8. Driver version is Catalyst 14.4.

$\endgroup$
  • $\begingroup$ Are you running out of memory? $\endgroup$ – gandalf3 Jul 9 '15 at 20:28
  • $\begingroup$ I don't think so. I've got another good 11GB of RAM it can use. As for the video memory, I don't know for certain, but there's nothing serious loaded and I get the same error with an empty scene with just a cube, light and a camera. $\endgroup$ – Adi Jul 9 '15 at 20:32
  • $\begingroup$ have you tried using blender version 2.75? $\endgroup$ – cegaton Jul 9 '15 at 20:32
  • $\begingroup$ Yup. Running 2.75a. $\endgroup$ – Adi Jul 9 '15 at 20:33
  • $\begingroup$ Sounds like you might want to try a report to the tracker $\endgroup$ – gandalf3 Jul 9 '15 at 20:36
1
$\begingroup$

The solution is the update the drivers. Version 15.07 works fine with 2.75a.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.