4
$\begingroup$

enter image description here

The wireframe on the right looks correct, but in object mode on the left, you can see that the upper and lower vertices are not connected, while the "box" to the right is fine.

I tried Fill and Merge Vertices, but both do not result in a correctly looking model. In wireframe mode, it looks great, but in object mode it does not.

I have uploaded my model here:

http://www.pasteall.org/blend/36955

Does anybody see what causes this weirdness?

Thank you for the help!

Here is another image: It shows that the 2nd "box" is not correct (it has greyish faces), while the 1st and 3rd are correct.

enter image description here

$\endgroup$
  • $\begingroup$ I don't know what is the exaxt puropse of this model, but I would warn you that you are creating a Non-Mainfold mesh. This could easly led to unespected behavior. I would suggest to separate the rectangular faces by spilitting vertex. $\endgroup$ – Carlo Jul 17 '15 at 10:12
3
$\begingroup$

Detach the glass panel from the 4 vertices around it (Select the Face, hit Y, this will make its 4 vertices unique).

Currently what you have is 'invalid' geometry, and it messes up the edge render routine. Blender allows you to create meshes that are not technically 'valid'. If you have edges which are shared by more than 2 faces that's a problem mesh, and you can expect weird behavior in recalculation normals and other operations / artefacts.

enter image description here

Another reason Blender will drop edges from the interactive view of the wireframe, is if their shared faces have the same Normals.

enter image description here

What you're experiencing might be the effect of those edges not having a clear Normal, because they are also shared by 3 faces.

$\endgroup$
  • $\begingroup$ that's what i meant in my comment, didn't see your answer :) $\endgroup$ – Bithur Jul 17 '15 at 10:51
  • $\begingroup$ Thank you. This fixes my errors. When I then select a face, I can press Del and "Dissolve Vertices" to remove the face. $\endgroup$ – tmighty Aug 1 '15 at 22:18
11
$\begingroup$

Blender doesn't show ALL edges by default in object mode.

enter image description here

To make all edges visible, go to Display Panel in the Object Context and check the "Draw all edges" box as in the picture.

$\endgroup$
  • 1
    $\begingroup$ After 5 months, I am still not familar with the tabs. Can you tell me where I can find the "Object tab"? $\endgroup$ – tmighty Jul 17 '15 at 0:42
  • $\begingroup$ @tmighty look at the screenshot. The object tab is represented by the yellow cube in the 'properties' panel (far right and top). $\endgroup$ – Bojidar Marinov Jul 17 '15 at 7:43
  • $\begingroup$ That's my fault... according to this I should have call it: Object context...I'll fix it in the answer $\endgroup$ – Carlo Jul 17 '15 at 9:37
  • $\begingroup$ object tab in properties panel seems right to me, some highlighting on the screenshot usually helps find what it is $\endgroup$ – Bithur Jul 17 '15 at 10:28
5
$\begingroup$

I downloaded your blend file, and examined it in both edit mode and object mode. Sometimes interior edges on a surface--like the two you are asking about, do not show. In this case, trust edit mode regarding the missing edges--they are there, but the reason that the apparently missing edges do not show is that the normal of the face between them is flipped to the opposite direction of the two similar faces on either side of the face that seems to be missing edges.

EDIT (to answer the followup questions you raised in your comment posted to this answer, and your comment to the answer posted by Carlo on 16 July 2015)

Open your ~.blend file in object mode, and find the place illustrated in the left half of the image you posted in your original question. Switch to edit mode, set selection to "edge" and select the two edges connecting what you point to with the red arrows as the "missing" edges. Switch selection type from "edge" to "vertex", and you should see the face bounded by the four vertices highlighted in orange. In the "shading/UV" tab of the tool shelf, in the shading panel, you will see the heading "normals" below which are two menu options: "recalculate" and "flip direction". Choose "flip direction".

Yes, there is a way to make Blender always show a face's direction. In the 3D viewport, in edit mode, if the toolshelf (the panels on the left side of the viewport) is not open, press the N key to open it. Scroll down the panels in the toolshelf until you find "Mesh Display". If it is closed (that is, if it only has a triangle pointing to the right), click on the triangle to open the panel. With the panel open, a bit more than halfway down the panel, you will see the word "Normals", with a selection bar beneath. To show the normals for faces, click on the "face" section of the selection bar. You will see blue lines from the selection box on each face pointing in the direction the face is pointing. If there are too many lines for you to tell which direction the normal is pointing for the face(s) you are interested in, select some of the faces you are not interested at the moment, and hide them by pressing the H key [Unhide them by pressing the combination ALT-H key]. The blue line starts at the selection point, and displays in the direction the face is pointing.

With respect to the "object tabs" you asked about, although when I opened the ~.blend file you posted, it appeared to be the default 3D view editing screen layout, with the Outliner editor window in the upper part of the column above the Property editor window in the loser. Still, it's possible that your screen layout does not show the properties editor window, in which case, you need to divide the screen by clicking on the widget in the extreme upper right, or extreme lower left of each window. Each window has two widgets, and they work the same way. Move the widget away from the corner in the direction away from where you want to add a new window. When you've divided the window, click on the icon at the extreme left of the header (which in the case of the 3D viewport is a mis-nomer, as the header is actually a footer), and find "Properties" in the menu that is generated. This will set the new window as a Properties editor window. The screenshot Carlos attached to his answer shows the default 3D editor screen layout. The far right column of the screenshot shows two windows: the upper one is the Outliner editor window. If you're not familiar with that window, it is a useful tool, and worthy of investigation on your part.

The lower part of the far right column in Carlo's screenshot is the Properties editor window. In the extreme upper left hand corner of the Properties editor window is the icon that identifies the window type. To the right of that icon are a number of tabs (the number, and the identifying icons on each tab varying somewhat depending upon what object is selected. For an mesh object, from left to right the tabs are "Render", "Render Layers", "Scene", "World" "Object", "Constraints", "Modifiers", "Materials", "Textures", "Particles", and "Physics". If you have the hut object active, and select the object tab, you should see a set of panels in the properties editor that contains the same headings as the panels in Carlos' screenshot; the object property tab is fifth from the right. When you select the object property tab, one of the panels that appears is one marked "Display". The "draw all lines" box Carlo refers to is the last item in the left hand column of the Display panel.

$\endgroup$
  • $\begingroup$ Have you been able to fix it by pressing Ctrl+N two times? I tried that, and I still did not succeed. $\endgroup$ – tmighty Jul 9 '15 at 12:52
  • $\begingroup$ I did not solve it by pressing CTRL-N twice; I did solve it by selecting the face with the apparently missing edges in object mode, and clicking on the "flip direction" button in the shading tab of the toolshelf. $\endgroup$ – brasshat Jul 9 '15 at 17:47
  • $\begingroup$ I tried that, but for me it did not work. Do you think you could explain it more? I am flipping around like crazy, but one face is always missing. Also, is there perhaps a way to make Blender show me a face's direction? $\endgroup$ – tmighty Jul 16 '15 at 19:00
  • $\begingroup$ the problem is the the glass part of your windows is connected. separate the glass or delete the faces inside (between the 2 sides of the glass). then you'll be able to use Ctrl+N without problem. $\endgroup$ – Bithur Jul 17 '15 at 10:42
  • $\begingroup$ @tmighty, your question about how to show blender's face direction should be its own question. Please ask it as a separate question, rather than in the comments as you did. When you've done so, I'll move the relevant bits of my answer to the new question. $\endgroup$ – brasshat Jul 17 '15 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.