1
$\begingroup$

I have a problem with Blender where UV maps for both of my materials are always visible in the UV/Image editor screen no matter what is selected in the 3D View. My model has 2 materials with texture image assigned to each of them: Walls material Walls image Internals material Internals image

A screenshot where all faces of first material ('Main') is selected below: Walls UVs

As you can see UVs of both materials (this 'crazy network' is UV of second material) are shown while only faces of first material selected. The same issue appears when second material selected - the image is changed to correct but both UVs sets are shown. The issue seems to be fixed when 'Keep UV and edit mode mesh selection in sync' unchecked but is this behavior fine for UV/Image editor screen? If not how can I fix this and remove unnecessary UVs from material?

Thanks in advance.

Edit: I uploaded the .blend file here

$\endgroup$
  • $\begingroup$ could you upload the blendfile? $\endgroup$ – gladys Jul 8 '15 at 8:03
  • $\begingroup$ The file is uploaded. Please, check the 'Edit' section. $\endgroup$ – Shoar Jul 8 '15 at 8:20
  • 2
    $\begingroup$ i think this behaviour is normal for the UV editor, maybe it is easier to seperate the objects in two objects the sides and the top. $\endgroup$ – gladys Jul 8 '15 at 11:02
2
$\begingroup$

The behaviour is normal.

Consider that in display textured mode you'll see the last selected texture in the UV/Image editor for the selected faces... so it may not be one of the material's texture. There's no correlation between the material texture and the textures shown in the textured mode of the 3d view, unless you keep it consciusly. So keep an eye on it...

I could not find two of you textures (Texture.png and Texture.png.001 are their names) so I have replaced them with my own creation: Untitled (all right reserved...!!!)

enter image description here

We have a single object with two material and two UVMap.

The second UVMap is "empty", ... well not really,.. let's say it not contains useful info as is collapsed. Remove it by selecting it and pressing the minus.

enter image description here

Now we have a single uv map, but as contain the info for both material, it shows them overlayed.

We can:

1) Select all the faces of one material (Edit mode, deselect all, material tab->Select) and hide them:

enter image description here

2) Duplicate the uvmap, rename, make active first UVmap, select first material faces, invert selection, make uv info related to these faces unobtrusive in the uv/image editor (move them away, or scale them to a 0 factor..). Than select second UVmap, second material faces....and repeat as above.

By selecting one of the UVMaps with one clock you are now able to see only the its relative UVinfo.

enter image description here

(Note: remember to update Image mapping coordinates in the material's texture, they must point to the correct UVMap)

enter image description here

In both methods you are not allowed to see the texture of the other material while UV editing one

3) Assuming that you have one map with UVs overlayed, you can:

  • Unselect all
  • Go to the material tab and select one material's face
  • Go to the UV/Image editor, select all visible
  • Set repeating coordinates
  • Shift your selection on the x-axis by the texturex with (in pixel)
  • Select all in the 3d view

enter image description here

Nothing should have changed, as the texture UV are repeated by default (if no clamp option by enabled), but now you can clearly see and edit both UV layouts

(Note: not shure what to do if the X size is different between textures..)

4) As suggested by gladys, split the objects in two and merge the parts only at the end is the fastest solution.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.