1
$\begingroup$

I have a model textured and every time I put Blender into Rendered View, these weird hard edged shadows show up as if I have vertices sticking out but they are clean.

enter image description here

Could this be a shadow settings problem or is it likely something to do with the texturing? I'm using the cycles rendering engine.

A copy of the ~.blend file can be downloaded from https://blend-exchange.giantcowfilms.com/embedImage.png?bid=322

$\endgroup$
  • $\begingroup$ Looks like z-fighting to me. Do you have another object underneath this one? $\endgroup$ – PGmath Jul 8 '15 at 0:45
  • $\begingroup$ No object underneath on the same layer. Other layers shouldn't matter, right? $\endgroup$ – Daniel Jul 8 '15 at 0:49
  • $\begingroup$ Right, other layers (as long as they are not visible) don't matter. Is there any duplicated geometry at those parts of the mesh? I am pretty sure what you are experiencing is z-fighting (the artifacts produced when two faces are occupying the exact same plane). $\endgroup$ – PGmath Jul 8 '15 at 1:59
  • $\begingroup$ Would it be possible to upload your .blend to a site like Blend-Exchange so we could take a look? $\endgroup$ – PGmath Jul 8 '15 at 2:03
  • $\begingroup$ Is your mesh similarly shaded across the boundary that you are identifying as "hard shadows? I can reproduce a very similar effect by setting the whole mesh to "smooth" face shading in the "shading panel" of the UV / Face tab, except for a couple of faces set to "flat". $\endgroup$ – brasshat Jul 8 '15 at 2:33