0
$\begingroup$

Following the release notes relating to the changes to time and influence controls on strips, I keep running into issues with it. When I check the strip to have animated time and try to insert keyframes, I get the error message "No F-Curve to add keyframes to".

I can locate the Strip Time track in the Graph Editor for the given object, but there's no curve. Odd enough, I can add modifiers to the track and they seem to work as intended (ie. time becomes animated), but I can't find a way to control it manually.

Am I missing a step here or could this be a bug of some sort?

$\endgroup$
0
$\begingroup$

I think what you are looking for is the animated setting for these properties. In the NLA Editor you will find an Evaluation panel in the properties sidebar N where you can enable animated for the time and influence of the strip and add keyframes.

On my first quick look at this it does appear incomplete. When you enable these two animated settings, it appears to be keyframed but there is no f-curve, but it does then allow you to add keyframes to the values which does create an f-curve that you can then adjust in the graph editor.

enter image description here

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ This seems like the proper way to do it, but the two ways I know how to add keyframes to numeric fields (right clicking the field / autokey) both result in an error. Can you check this screencast and spot what I'm doing wrong? drive.google.com/file/d/0B0ENQEs_rHwsTWxWbHJHWWQ1ZjA/view $\endgroup$ – volvis Jul 3 '15 at 5:49
  • $\begingroup$ I'd say report it as a bug, when I enable the animated checkbox the time highlights as if it is animated and I can create keyframes. First "Load Factory settings" and try in case an old startupfile is introducing your error. $\endgroup$ – sambler Jul 8 '15 at 17:23
  • $\begingroup$ Hello, I have same problem, so it is bug? I can not add keyframes to Influence? $\endgroup$ – Cenda Aug 20 '15 at 14:14
0
$\begingroup$

So it looks like bug, because it works good in last developer build. But I found workaround. If you want add key to curves, you have to activate View > Show sliders in F-Curve editor. Turn on autokey and change value.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.