2
$\begingroup$

I'm trying to composite a shockwave effect with the blender render engine.
My scene is currently set up with two render layers:

Layer one: Text, two lamps and a camera.
Layer two: shockwave.

I have two issues currently, however I think the first issue may be beyond the scope of this question, I'm not entirely sure if it's something to do with the layer comp.

Issue One: The shockwave colouring seems not to be working from certain frames. Even though nothing is keyframed, everything seems to desaturate from frame 40 to about frame 100.

Issue Two: The final render is rendering the shockwave layer in front of the text when the object is behind the text. If I switch the alpha mix over node's inputs none of the actual shockwave renders, only the text layer.

Download the Blend

Current Output

$\endgroup$
  • $\begingroup$ Please post your blend or at least screen shots so we can help you further. $\endgroup$ – Todd McIntosh Jun 30 '15 at 15:35
  • $\begingroup$ added the .blend $\endgroup$ – Neil Hickman Jun 30 '15 at 15:38
  • $\begingroup$ Doesn't seem to download for me. Clicking the download button does nothing. I'll try again later. $\endgroup$ – Todd McIntosh Jun 30 '15 at 15:42
  • $\begingroup$ I've changed it to a dropbox link now, that should work. $\endgroup$ – Neil Hickman Jun 30 '15 at 15:44
  • $\begingroup$ Ok, got it. Everything seems to be on one layer. I thought you were compositing 2 layers together? $\endgroup$ – Todd McIntosh Jun 30 '15 at 15:48
2
$\begingroup$

Ok, there are a number of issues with your file:

  1. Select Layers 1 and 2 in the viewport to have both layers render.

enter image description here

  1. In the Render>Shading panel you should select Transparent instead of Sky for the Alpha setting. This will allow your Text layer to render with an alpha channel instead of black.

enter image description here

  1. Secondly, your Hue/Sat compositing node affecting the Shockwave layer IS keyframed on the Value field. Try muting it to see the difference.

enter image description here

  1. Reverse the inputs on your Alpha Over node to put the shockwave behind.

enter image description here

enter image description here

The shockwave image is very light when viewing in Color+Alpha mode in the UV/Image Editor. If you switch to Color only you can see a stronger effect. Alternatively, you could composite a black background behind everything to see it better.

enter image description here

$\endgroup$
  • $\begingroup$ Changing the shading alpha to Transparent has just given me a full blank image. $\endgroup$ – Neil Hickman Jun 30 '15 at 16:14
  • $\begingroup$ What are you looking at when you see the blank image? The Render Result or the Viewer node in the Compositor? Check your individual render layers to see what is rendering for each layer. $\endgroup$ – Todd McIntosh Jun 30 '15 at 16:39
  • $\begingroup$ I'm looking at Render result. $\endgroup$ – Neil Hickman Jun 30 '15 at 16:41
  • $\begingroup$ Could be your composite node is giving a blank image, but the render layers are correct. You can change the view in the Render Result to just see each Render Layer output separately. What does that show? $\endgroup$ – Todd McIntosh Jun 30 '15 at 16:42
  • 1
    $\begingroup$ You can re-enable the HueSat node, but you have to duplicate the key at frame 188 and move it to frame 1, so that it has a starting value. $\endgroup$ – Todd McIntosh Jun 30 '15 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.