1
$\begingroup$

UV textures appear scrambled or missing when rendered, but are fine in the 3D view. I've spent the entire day googling and looking at other people's problems and I am still at a loss. I want to render now but I can't seem to figure out what I'm doing wrong.

Screenshot

Blendfile

Am I missing something obvious? I have more than one UV on a character and want to know if it's possible to assign different materials to different parts.

Sorry if I'm not providing enough details. If you have questions, I'll try to answer right away.

$\endgroup$
  • $\begingroup$ Would you mind uploading a .blend of your project file (be sure to pack textures, Flie > External Data > Pack all into .blend before you save the file for upload), and add it to your post, as an edit. $\endgroup$ – GiantCowFilms Jun 28 '15 at 19:02
  • $\begingroup$ I added the file! $\endgroup$ – emengel Jun 28 '15 at 19:34
  • 1
    $\begingroup$ The textures appear to be missing in your uploaded file. Did you pack the textures before uploading? $\endgroup$ – gandalf3 Jun 29 '15 at 19:50
1
$\begingroup$

You have only 1 UV on each character and your UVs intersect. enter image description here enter image description here

| improve this answer | |
$\endgroup$
  • 2
    $\begingroup$ Please add more to this answer. $\endgroup$ – David Jun 28 '15 at 22:58
  • $\begingroup$ Perhaps you could explain how to fix these issues? $\endgroup$ – gandalf3 Jun 29 '15 at 3:22
  • $\begingroup$ Is there a way I can amend this issue? $\endgroup$ – emengel Jun 29 '15 at 14:45
1
$\begingroup$

I looked at these two tutorials:

https://www.youtube.com/watch?v=MqmXqgbzIxg
https://www.youtube.com/watch?v=mNtIX5BZmzc

Which allowed the characters to have their full skin map and t-shirt design map to be separate - and no overlap. (Creating UV Maps under Data with the appropriate mesh selected. Then creating a material and texture - making sure the correct UV map was selected under Mapping. And lastly, "assigning" the material to the piece.)

And then this tutorial allowed me separate UV's that had transparency to render! (Selecting Face Textures and Face Textures Alpha under Materials > Options).

https://sketchfab.com/models/cf6bf7d8729f479ab0522e73317b29fe

| improve this answer | |
$\endgroup$
  • 2
    $\begingroup$ This does not really answer the question. Please add more, or include important steps from the tutorials. $\endgroup$ – David Jun 29 '15 at 22:16
1
$\begingroup$

Make sure that each single UV map has been assigned to its object. If you can't select each part:

  1. Switch to Edit mode
  2. Hover your mouse over the part you want to select and press L. The part will be highlighted.
  3. Now assign your UV map.
  4. Switch back to object mode, click on the general object and repeat these steps with each single part from step 1.
| improve this answer | |
$\endgroup$
0
$\begingroup$

From the looks of it all you normals are inverted for one.

A black mesh can mean your materials aren't connected or you're using adaptive subsurf with a normal map set to tangent space.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.