2
$\begingroup$

This question already has an answer here:

My .blend file can be found here.

When I view the simulation in the viewport, it looks normal, like this:

viewport

When I view it in the render preview with SHIFT+Z viewport, it looks perfect:

render preview

But when I render with F12, it's strangely transparent and looks odd!:

final render

Here's my node setup:

nodes

Also, try viewing the images on imgur directly. It's more apparent what the problem is.

Ignore the funky flow shape. Thanks in advance.

$\endgroup$

marked as duplicate by David Jun 25 '15 at 14:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2
$\begingroup$

Unfortunately, (as mentioned in the linked thread), this issue is a bug.

There is a workaround however, which isn't ideal or 100% polished, but its a quick and dirty method to get the job done.

1. As you can see in the screenshot, I have the same issue (Note: This bug only applies to the 'Fire' flow type, the 'Fire & Smoke' type renders without issues).

Image 1

2. Begin by ensuring that Transparent is checked under Film in the Render Properties Panel, and also that the PNG Type is set to RGBA in Output.

Image 2

3. Next add a large plane behind the fire object. Ensure that it is wider than the bounds of the camera and is far enough back from the fire object as not to cast light onto it. Give it a simple deep blue emission shader, with strength set to 1. (Note: I've noticed a bug here in 2.74 whereby if there is an object behind the viewport display of the smoke and fire, it wont dispay properly. Don't worry though, this doesn't seem to affect the renders.)

Image 3

4. Render the image and jump on into the Compositing Screen Layout. Check the Use Nodes, Free Unused, and Backdrop boxes below the Node Editor, and add in a Viewer node.

Image 4

5. Hit Shift+A and go Matte>Keying, add this to the Node tree.

Image 5 Image 6

6. In the Key Colour setting, use the Eye Dropper tool to sample the blue from the original render, this will mask out all hues from the render which display the selected colour. If the blue appears black, it's likely that you don't have the Use Alpha check-box ticked on the Viewer and Composite nodes.

Image 7

7. This should update the render automatically in the bottom left Image Editor. If it has simply hover over the transparent render and hit F3. If not just give it another render, ensuring that the Compositing check-box is ticked under the Post Processing tab in the Render Properties Panel, and it should display the composite fine.

Image 8

Et Voila, the final render! :) As I mentioned it's not a perfect solution, and where the blue was subtracted from the edge of the flame it has become slightly pink tinted, but for all intensive purposes it works okay, and colour correction could be applied either in Blender or in Photoshop/Gimp. Finger's crossed the bugs'll be fixed in the next release.

Image 9

$\endgroup$
  • 1
    $\begingroup$ Because I'm rendering a video (no alpha allowed anyway), I was able to make the emission plane completely black, and it now looks fine. Thanks for the idea! $\endgroup$ – Poyo Jun 25 '15 at 18:30
  • $\begingroup$ No worries, glad I could inspire your fix! ;) $\endgroup$ – Hexbob6 Jun 25 '15 at 20:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.