7
$\begingroup$

I added a texture to the bowl, and it came out rendered black. I unwrapped it, and I did a little node editing, to make the plane glossy and B&W. It looks fine in the preview, as well as in material view, and in rendered view, but not in the render.

Another weird part is that Suzanne is also black in the render, even though she just has the default light gray material and no node editing at all. If I render without the bowl, it's just Suzanne in black. I have no idea why this is happening.

Here's my bowl's nodes: bowl nodes

And here's rendered view

rendered view

And here's the render

enter image description here

There's definitely a light in the scene.

$\endgroup$
  • $\begingroup$ Can you post the blend? $\endgroup$ – Todd McIntosh Jun 25 '15 at 6:09
  • $\begingroup$ Was it working before you tried to apply the texture to the bowl? You'll have to update your post with a .blend file. $\endgroup$ – TARDIS Maker Jun 25 '15 at 6:10
  • $\begingroup$ @TARDISMaker I never rendered it before I applied the texture so I have no idea lol. And yeah, I'll upload a .blend $\endgroup$ – IntrepidPig Jun 25 '15 at 6:15
  • $\begingroup$ I found the issue, I'll have an answer up in just a few minutes $\endgroup$ – TARDIS Maker Jun 25 '15 at 6:42
  • $\begingroup$ Me too, Render Layer mask layer... $\endgroup$ – Todd McIntosh Jun 25 '15 at 6:57
11
$\begingroup$

I think what happened here was just a misclick in your render layer settings. It looks like you accidentally added a layer as a mask layer.

What is a mask layer

A mask layer is a layer that is used as a mask to turn parts of a renderlayer transparent depending on if anything (that appears in the render) is infront of something from that renderlayer.

What's the issue?

Your issue, is that you have your first layer (the one that has all your objects on it), set to be a mask layer, so essentially what is happening, is that instead of rendering the objects, there shape is filled with transparency. I just doesn't appear transparent because you don't have film transparent checked.

To fix this, simply uncheck that layer from the mask layers. enter image description here

$\endgroup$
  • $\begingroup$ I had a similar problem, but the issue was that the Material field in RenderLayer had a material in it, pressing the x on it cleared it and there after renders worked. $\endgroup$ – Lucas W Dec 30 '17 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.