Just learning here... I created a model in Makehuman and imported it into Blender. When I pose the model I get really ugly creases where the mesh appears to overlap:

Reference Image

How do I clean this up or avoid it? I'm not worried about animating or anything I just want it to look smooth.

  • 2
    $\begingroup$ Proper weight painting will help avoid problems like this $\endgroup$
    – ruckus
    Commented Jun 24, 2015 at 19:19
  • $\begingroup$ Add another bone in between the 2 bones with average rotation $\endgroup$
    – Vlad
    Commented Nov 29, 2017 at 17:31

1 Answer 1


Typically its best to first attempt to resolve the issue by weight painting.

That is to adjust the weights around the joint to improve the deformation.

  • Adjust weight values by manually painting.
  • Use the smooth tool to automatically re-distribute weights (new in 2.76), eg: smooth result
  • Try the 'dual quaternion' option in the armature modifier
    (helps avoid volume loss),
  • When weight painting can't quite resolve all artifacts,
    try the corrective smooth modifier (new in 2.75)
    corrective smooth

  • Corrective shape keys
    Using a shape key to manually correct the distortion. While its involved to setup, it can be driven by bone and gives most control, This is typically used for more advanced rigging.

  • $\begingroup$ Thanks. I don't have the "corrective" smooth modifier (not sure why) but the regular smooth modifier appears to releave some of the distortion. I will play with the weight / quaternion values as well once I'm further along. $\endgroup$ Commented Jun 24, 2015 at 20:36
  • $\begingroup$ @mister martin, its in 2.75 which isn't released just yet, but suggest trying the release-candidate, since I think it does exactly what you need (assuming some simple tweaks to weights don't resolve). $\endgroup$
    – ideasman42
    Commented Jun 24, 2015 at 20:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .