I'm using Linux Mint and I was trying to enable GPU rendering, but I still have only CPU option in user preferences...

  • Linux Mint 17.1 x64
  • Radeon HD 7850
  • Blender 2.75 rc2
  • amd-catalyst 15.5

solved by myself

  • Maybe this is useful :) : anteru.net/2014/08/24/2500 – Faceb Faceb Jun 24 '15 at 18:11
  • thank you, but i seen that and it's not working for me, that's why i'm here – Dmitry Jun 24 '15 at 18:34
  • what have you tried to get it working? have you read the GPU guide blender.org/manual/render/cycles/gpu_rendering.html ? – wardrums Jun 25 '15 at 5:17
  • i was trying to set up environment variables ( CYCLES_OPENCL_SPLIT_KERNEL_TEST=1, and CYCLES_OPENCL_TEST=all ), running Blender as root, installing Blender from software center and repeat same. yes i read that before (GPU guide) – Dmitry Jun 25 '15 at 10:09

I have found solution to my problem. To enable openCl on Linux Mint 17.1 with ATI radeon video card just install ocl-icd-libopencl1 package for 64 bit system, or ocl-icd-libopencl1:i386 for 32 bit system. No need to run Blender as root or set up environment variable.

On Ubuntu open the Terminal and do:

 sudo apt-get install ocl-icd-opencl-dev

then:

CYCLES_OPENCL_SPLIT_KERNEL_TEST=1 blender

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.