1
$\begingroup$

I've got problems with Blender Normal bake. I'm Trying to bake a set of High res (sculpted) Teeth to a low poly model of the teeth.

In the normal map I see some spots that stay purple, the normal map doesn't bake to this piece of the map. I think it has something to do with the bake settings, but I need some help, how to control them.

And I get some strange colors like green and orange.
Strange colors in normal map Applied normal map to low poly model
When I apply the normal map, as you can see it's really ugly.

Here is a link to the Blend file: teeth.blend

$\endgroup$
  • $\begingroup$ Welcome to Blender.SE. I cannot answer your question, but I took the liberty to make a minor edit to your post. Specifically line break formatting. You may find this page helpful for formatting your posts. And for your question, it may be important for someone who actually can answer it to know whether you're using Cycles or Blender internal. $\endgroup$ – user7952 Jun 23 '15 at 8:16
  • $\begingroup$ @Sandra Vissers, I, too extend a welcome to the site. Those who might wish to help might find it useful, besides knowing whether you're using Cycles or Blender Internal as the rendering engine, will also very likely find it valuable to see a copy of your ~.blend file, with necessary images packed in. $\endgroup$ – brasshat Jun 23 '15 at 8:34
  • $\begingroup$ Thnx for the advice guys $\endgroup$ – Lexa Vissers Jun 23 '15 at 13:24
  • $\begingroup$ The texture images are missing from your .blend file. You can include them in your file by clicking on the highlighted menu item in the screenshot. You may first want to save the file under another name so as not to alter your working version. Oh... I'm new here too, and the image can only display from an answer, not a comment so see below. $\endgroup$ – Chris Hanning Jun 24 '15 at 10:01
  • $\begingroup$ a hint as to including texture images in your uploaded .blend file: pack external data $\endgroup$ – Chris Hanning Jun 24 '15 at 10:03
1
$\begingroup$

Using Cycles I was able to achieve the following result using the meshes from your .blend. Not sure why your image has the funky artifacts, but as far as I can see the result I turned out seemed okay? I'll add the steps of how I achieved the result below... :)

UV MAP1

1. To begin, after deleting all previous mesh data (Materials, UV Maps, etc- helped me to start afresh) and with the multires mesh selected, add a new 2048x2048px image in the UV Image editor. Then create a new Cycles material with this image attached to the diffuse colour (as this image needs to be applied to the multires mesh in order to bake the normals, and plugging it to the diffuse colour will help us view it in Textured View Mode later on if need be).

Image1

2. Next enter edit mode and UV Unwrap the multires teeth mesh onto the new image.

Image 2

3. Now we can head over to the Render settings in the properties panel and jump to the Bake tab. Change the Bake Type: dropdown to 'Normal'.

Image 3

4. You can change the Margin to be '0px' and check the Clear box beneath it. This'll just make the normal map look a bit cleaner, you can leave it at higher values if desired, it shouldn't affect the normal map. Finally, hit Bake!

Image 4

And there ya go! You can save the UV Map externally by tabbing out of edit mode, hovering over the Normal Map in the UV Image editor and hitting F3. Hope this helps! :)

$\endgroup$
  • $\begingroup$ Thnx Hexbob6, youǘe explained it clearly, Unfortunately there's something going wrong with the bake process. Blender cannot find an image to bake to, the message I get is: No active image found in material. Do you know what Iḿ doing wrong here? $\endgroup$ – Lexa Vissers Jun 26 '15 at 8:49
  • $\begingroup$ No worries Sandra, yes I think I encountered that when I was having a play about with it. Just make sure you add a new image in the UV Image editor, name it something obvious so it's easy to find, then make sure its selected when you add the Image Texture node. Then try baking the normals :) $\endgroup$ – Hexbob6 Jun 26 '15 at 14:40
  • $\begingroup$ Oh and ensure that the object that has the material is unwrapped and selected in edit mode when you hit Bake! :P $\endgroup$ – Hexbob6 Jun 26 '15 at 14:42
  • $\begingroup$ Hey Hexbob6, I indeed didn't bake from Edit mode. but that wasn't the problem. I looked in the outliner, and I cannot seem to assign a texture to the material. So blender doesn't find a texture by the active material. I tried to unlink al the materials and start from fresh, but it still doesn't work $\endgroup$ – Lexa Vissers Jun 28 '15 at 8:45
  • $\begingroup$ Ah sorry, I think that was bad explaining on my part, you dont assign the texture from the outliner, you create it in the UV Image Editor, and then assign it to the Image Texture node, in the material Node Editor. I'll put a screenshot here hopefully explaining what i mean a bit better :) pasteall.org/pic/90011 $\endgroup$ – Hexbob6 Jun 29 '15 at 1:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.