I've been trying to put together a smoke sim in blender 2.74 using the quick smoke preset however have found that it does not show up in the viewport, yet will still render.

Long story short i have recently updated my AMD Radeon 6750M drivers and it has given me some issues with using the older versions of blender (2.71>), however i have apparently now managed to fix that issue with the error126 fix.

I had initially thought that the smoke not showing up was an opengl issue caused by the drivers, (especially since opengl render no longer works for me), however having now been able to use 2.71 again i have found that not only does the smoke display in 2.71s viewport, but i can also opengl render in 2.71?!

I've attached 3 screenshots of blender 2.71, 2.72b and 2.74 each with the default cube having a quick smoke preset applied to it and the animation played to frame 70. As you can see there does not seem to be any issues with the viewport in 2.71:

2.71 Works!

Yet nothing displays in 2.72b and 2.74:

2.72b Doesn't! Neither does 2.74!

This has lead me to ponder if blender uses a different opengl version from 2.72 onwards, or whether there's just something blindingly obvious I'm missing (wouldn't be a first! ;) )?

Anyone have any ideas? Thankyou in advance!

Samsung Laptop running Windows 7 x64
Quadcore Intel i7 CPU
AMD Radeon 6750M GPU and Mobile Intel(R) HD Graphics(?)

EDIT:- Just downloaded the 2.75 Release Candidate, same issue as 2.74, however when i opened the application i was greeted by this message (does not appear when opening 2.71):

Opengl issue?

  • $\begingroup$ In response to @MrZak on the previous post, i have tried copying them in seperately now, but as they're already in the folder it understandably won't let me now. And yes I used the AMD Catalyst (i think it's called) software from their site to update the correct driver :) $\endgroup$
    – Hexbob6
    Commented Jun 21, 2015 at 11:49
  • $\begingroup$ "as they're already in the folder it understandably won't let me now" - it will. You should enter "copy 'filename'.dll .dll" (typing name of that file without quotes instead of 'filename'). And shutdown every program using OpenGL (Blender for example). But I believe this discussion becomes offtopic here $\endgroup$
    – Mr Zak
    Commented Jun 21, 2015 at 12:02
  • $\begingroup$ Ah my bad, you were right i had missed the extra .dll! Unfortunately it still hasnt solved the issue however :( It just seems odd to me that it works perfectly fine on a previous version, yet not at all on a later one, unless blender was processing something differently. $\endgroup$
    – Hexbob6
    Commented Jun 21, 2015 at 12:27
  • $\begingroup$ What version of OpenGL library do you have ? (there are some tools for checking that - realtech-vr.com/glview, but you can do that inside of Blender, selecting in the main menu Help > System Info, then switching one of Blender windows to Text Editor window and selecting system-info.txt) $\endgroup$
    – Mr Zak
    Commented Jun 22, 2015 at 12:49
  • $\begingroup$ Not sure which bit is the specific library version (1.1.0 maybe?) but this is what the system-info.txt says. OpenGL ============================================ renderer: 'GDI Generic' vendor: 'Microsoft Corporation' version: '1.1.0' extensions: 'GL_WIN_swap_hint GL_EXT_bgra GL_EXT_paletted_texture' Implementation Dependent OpenGL Limits: ============================================ Maximum Fixed Function Texture Units: 0 $\endgroup$
    – Hexbob6
    Commented Jun 23, 2015 at 12:49

1 Answer 1


Found the solution!

It was simply the case that Blender no longer used the updated AMD GPU as the primary card when running Blender, and instead used the Intel card which was not up to date. Consequently parts of Blender which require OpenGL (such as the viewport smoke simulation or OpenGL render, in my case) will not display correctly, or will throw up errors when used. This is easy to fix by reconfiguring which card is used when running the app.

This was the steps taken for my Windows 7 x64 laptop.

1) Right Click on the Desktop, select the Graphics Properties option from the drop down menu. Note: If there is a Configure Switchable Graphics option (as shown in the screenshot), click that instead and skip to step 3.

Fix Image1

2) Under the Power tab, click Switchable Graphics Application Settings.

Fix Image2

3) This will bring you to a window with Recent Applications and All Applications drop down menus. Don't be fooled if you see Blender in the 'all applications' menu, if there are multiple versions saved on the same machine yet under different file locations, you will sometimes need to configure each individually. To do this click the Add Application button by the dropdown.

Fix Image3

4) Navigate to the file location that the Blender Version is saved at. Select the app and hit Open.

Fix Image4

5) When you do this you will be brought back to the All Applications drop down menu. The selected app will now be highlighted (in this case it is the same app as was already on the list at the outset) and will have a drop down menu on the right hand side. Click the menu and choose High Performance. This will set the AMD graphics card as the primary driver used when running Blender.

Fix Image5

6) Click Apply and restart Blender. This should hopefully fix any issues, however you may need to repeat the process when installing later versions! :)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .