5
$\begingroup$

The Problem I'm encountering with Freestyle line renders.

Large Gaps appearing in external contour. I've disabled any modifiers and have troubleshot the issue extensively using other "gap fix" procedures & recommendations. Error appears to occur at very acute angles, but line-render isn't tied to occluded freestyle edges. Error somewhat affected by rotation of object

$\endgroup$
  • $\begingroup$ Related: blender.stackexchange.com/q/3735/599 $\endgroup$ – gandalf3 Jun 20 '15 at 6:25
  • $\begingroup$ Already attempted methods mentioned in issue: blender.stackexchange.com/questions/3735/… Did not solve the problem. $\endgroup$ – Steve Zapata Jun 20 '15 at 6:28
  • $\begingroup$ Do you have the Face Smoothness option enabled? Do you also have the same problem if you change the camera from perspective to orthographic (and vice versa)? $\endgroup$ – T.K. Jun 20 '15 at 8:37
  • $\begingroup$ Face Smoothness is enabled. Problem occurs in both Ortho and Persp. $\endgroup$ – Steve Zapata Jun 21 '15 at 0:49
  • $\begingroup$ What is the shading (either Flat or Smooth) in the problem area of the mesh data? If the Smooth shading is used, do you also have the same problem when the shading of the problem area is changed to Flat? What happens if you disable the Face Smoothness option? I guess this issue is caused by an unknown bug related to line visibility. $\endgroup$ – T.K. Jun 22 '15 at 0:14
1
$\begingroup$

I ran into a similar issue, in my opinion this is a bug ocurring when working with larger geometries. Try scaling your geometry down (dimensions below 100 units) and try again.

For bigger geometries sometimes whole lines or part of lines (always when crossing with hidden lines as seen from the camera) are disappearing, this goes away when simply scaling down. See the screenshots below.

Partly disappearing line in large geometry, hidden line shown for emphasis

Partly disappearing line in large geometry

The issue occurs when the geometry dimensions are >100 units, scaled down, the freestyle lines work as expected.

I've file a bug report here, including a testfile: https://developer.blender.org/T49479

Update: According to the bug report, this bug has been fixed end of December 2016 and should not occur anymore in newer versions of blender.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.