4
$\begingroup$

I'm making an armchair and I already did the body. When I UV unwrapped it and textured it, this was the result:

enter image description here

Here you can see the arm of the armchair. The top of the arm and the visible side have been UV unwrapped separately (this was intentional), the selected edges mark where the UV-unwrapped mesh was separated. The problem is, which you can see in the picture, that this separation has been stretched far too much towards the side. This is caused by the subsurf, since there's no problem with the model when subsurf is turned off, as seen in the picture:

enter image description here

One solution which will possibly reduce this effect is making more faces on the side close to the separation, like this (shown in red):

enter image description here

Even this will only be reduce the stretching instead of completely solve it. I haven't tried this yet because of the time I would have to spend re-moddeling, re-unwrapping and re-texturing, which you probably know consumes a lot of time. If you'd like, you can download the model here, I would also appreciate other tips on how I can make the armchair even better.

So can the stretching be fixed in some other way, rather than re-moddeling?

Thanks for reading!

$\endgroup$
  • $\begingroup$ It seems to be that you should unwrap mesh after adding / applying modifier to the object (because it changes vertices' position). So if refresh unwrap (so reunwrapping is solution imo), the object will look like this - i.imgur.com/nkPuuWS.jpg. Also I'd like to add that you'd better avoid of such big amount of triangles / ngons, especially in the noticeable places. Subsurf doesn't work very good with many triangles. $\endgroup$ – Mr Zak Jun 17 '15 at 14:25
  • $\begingroup$ The problem is that if I apply subsurf modifier I will have all these tiny faces instead of the ones I already have. This would make modelling the chair in the future a serious problem, you know what I mean? $\endgroup$ – Espen Sales Jun 17 '15 at 14:45
  • $\begingroup$ Wait, how did you unwrap the mesh with all the small faces? Is there something I'm missing? >_> $\endgroup$ – Espen Sales Jun 17 '15 at 14:48
3
$\begingroup$

While you have Subsurf Modifier on your model, hit U button and select Unwrap from the menu, then hit F6 button to bring Unwrap menu or in the Unwrap operator panel select Use Subsurf Modifier

enter image description here

$\endgroup$
  • $\begingroup$ When I press f6, it's not the Unwrap menu that pops up, and I don't know where to find it manually... a little help`? $\endgroup$ – Espen Sales Jun 18 '15 at 9:02
  • $\begingroup$ F6 will work right after you do the unwrap operation. $\endgroup$ – Denis Jun 19 '15 at 0:46
  • $\begingroup$ But when I press unwrap, my whole UV layout (which i spend lots of time making) is discarded and replaced by a generated version! And then, yes, the "Use subsurface modifier" option will pop up when I press f6, but then I lost the UV-layout... Can i do this without destroying it? $\endgroup$ – Espen Sales Jul 26 '15 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.