1
$\begingroup$

I have a very simple node set up as below for a leaf texture which is a transparent backgrounded png file. When I use the transparent shader with alpha node, I still get the white backround appearing as below, I can't figure out what's the problem here, please help.

Render view

enter image description here

nodes

enter image description here

PNG file

Blender file

thanks a lot

Ps. I went through questions already asked here for this subject, they didn't solve my problem, even though it's a very simple node set-up - sorry if it's a duplicate which I haven't seen yet

$\endgroup$
5
$\begingroup$

Open up the Node Editor, select the image texture node, then open the Properties Panel N and enable Use Alpha.

enable alpha

$\endgroup$
2
$\begingroup$

I opened your file, everything is OK, even in render view. In your photo it seems that the leaf is projecting a shadow on an object just underneath; is there a duplicate? I hope it can be helpfulenter image description here

$\endgroup$
  • $\begingroup$ it's only one leaf, but for some reason png files transparent parts didn't recognised by blender, then i open my png file and saved it as png again , it worked this time, i don't know how it didn't in the first place..thanks for the answer btw $\endgroup$ – ideorium Jun 16 '15 at 9:04
  • $\begingroup$ @ideorium I have had the same issue, IDK if it is a bug or what $\endgroup$ – VRM Jun 16 '15 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.