0
$\begingroup$

When I turn an object (with an emission shader) in my scene on it makes part of the scene actually go darker.

The light in question is on the outside of a vehicle (which has lights on the inside of the vehicle too) The light on the outside of the vehicle cannot reach the inside of the vehicle as it has no path.

I have made a quick example of the problem. But the problem I am seeing is more pronounced than this example, in my scene even if I turn the samples up to 2000 I never recover the light and it still appears darker and more grainy.

Here is a quick 100 sample render with the light disabled:

light off

And here is a render with the light enabled:

light on

Notice that in the second picture that the scene inside the vehicle actually becomes darker

What can I do to tackle this issue???

Update

I have got clamp Direct set to 4 and indirect set to 2 which tackles a lot of the grainy-ness but adding this light just makes my scene look terrible... but i need this light as it is integral to the scene.

| improve this question | | | | |
$\endgroup$
  • $\begingroup$ It looks like it's just because of noise. Try cranking up the samples, and try enabling multiple importance sampling on the light inside. $\endgroup$ – TARDIS Maker Jun 13 '15 at 2:34
  • $\begingroup$ Genius, I actually did the reverse but hey... turning multiple importance sampling OFF for the lights outside did the trick. I'm not sure now if I'll get the problem in reverse but it is way less important to have problems outside the vehicle as all the action, ahem, not like that, is happening inside. If you added an answer describing multiple importance briefly I'd happily accept it. $\endgroup$ – Neilos Jun 13 '15 at 2:53
  • $\begingroup$ What happened there, is you where telling Blender that those lights where more important than the lamp inside, so it was throwing more samples there, and it made everything else noisier. I'll write up an answer in a second. $\endgroup$ – TARDIS Maker Jun 13 '15 at 2:55
  • $\begingroup$ Done. I'll probably make some changes to it, but in general I'm done. If it's not specific enough, let me know. $\endgroup$ – TARDIS Maker Jun 13 '15 at 4:13
2
$\begingroup$

What's happening here, is you have your light inside. Cycles is throwing a lot of samples there because there aren't any other lights. Then, you added your other light and it had multiple importance enabled.

Cycles will of coarse have to throw some samples at that light, so that in it's self will make it noisier, but in addition to that, having multiple importance on, tells Cycles that that light is more important than the other light, so it throws even more samples at it.

So basically what you're seeing, is your render getting noisier, and therefore appearing darker, because of the extra lights.

| improve this answer | | | | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.