6
$\begingroup$

I created a basic male figure and rigged it using the rigify add on. I also created a simple walk animation action.

I attempted to turn the rigged model into a game character inside the blender game engine by following the Blender Game Engine: Simple Character tutorial by blender cookie.

I am having problems when setting up the game logic:

Sensor: Keyboard Up Arrow -> Controller: And -> Action: Loop End “Walk” 

When I run the game the model defaults to its standing pose (unrigged pose?) and nothing happens when I press .

As in the tutorial I tried to set the Relation Parent of the Model to the Rig with the parent type Armature and removed the armature modifier. This seemed to have no effect.

Any ideas as to why the action is not running in the game engine?

I am using Blender 2.68a

Edit: As requested, you will find a link to a zip with 2 blend files here. One is before game logic was applied and the other is with the game logic applied.

$\endgroup$
7
+50
$\begingroup$

In one of the files you sent, RigRichardMaleGame.blend, you did several things wrong, the two most significant being that you moved the metarig away from the generated rig instead of just hiding it. See #4 here.

That next thing you did wrong was remove the Armature modifier from the base mesh, this is what links the mesh to the rig. Your animations will playback in the viewport as these have already been keyframed but the game engine's Action Actuator needs this to know what mesh to associate the selected action with. The action was playing in the game engine, the mesh just wasn't being updated (hence why it went back to the default pose).

So to fix, just add an Armature modifier to the mesh and select the hidden rig which is the proper (unmodified) one, (metarig).

NB: I would highly suggest not revisiting that scene at all. It's very botched (in terms of scene settings, scale and organization) and would no doubt lead to a plethora of further errors down the line. I would instead recommend appending out the base mesh, rigging it again (a matter of minutes using Rigify) and then reanimating and making sure this time to not remove the armature modifier or mess too much with the generated rig.

$\endgroup$
  • $\begingroup$ Haven't been here for a while, will give it a shot. Pardon my mistakes as I am a Novice in 3D in general. Thanks for looking at my files. $\endgroup$ – Drahcir Jan 22 '14 at 14:42
1
$\begingroup$

I struggled with this for a few days. Suddenly I had an epiphany, I tried moving the armature to the top of the modifier stack, boom it worked.

Make sure the armature is at the top of the modifier stack.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.