7
$\begingroup$

I have a particle system that adds some details to a texture. However when I bake the texture down, any area that is transparent makes the bake transparent, even though there is another object beneath the transparent one. It appears that the default Bake Mode Full Render setting renders as if the Alpha setting under Shading (render tab) is set to Transparent.

When baking objects on to a texture, how can I disable alpha and just get the color as it would be in a render (reflections/refractions of the sky instead of Alpha pixels making holes)?

Note: I am making the particle system real and joining it first, so that it correctly renders and does not make the black silhouettes. Id prefer an internal render solution if possible, but a cycles one is ok too!

$\endgroup$
3
  • $\begingroup$ Add any extra notes into the question itself by using the 'edit' link below the question. $\endgroup$ Jun 11, 2015 at 19:09
  • $\begingroup$ Could you post images of what's happening versus what you expect to happen? It's a little difficult to picture. $\endgroup$
    – Matt
    Jun 29, 2015 at 20:13
  • 3
    $\begingroup$ In the UV/Image Editor, if you open up the image you want to use as the bake output, and look at the properties panel, there is a "Use Alpha" checkbox. Have you tried deselecting that checkbox prior to baking? $\endgroup$
    – YoeyYutch
    Jul 10, 2015 at 1:36

1 Answer 1

1
$\begingroup$

Turn off transparency in the Render properties. In cycles it can be found under film and in blender render it can be found under shader. Or you could just add a plain as a background.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.