4
$\begingroup$

I'm a bit new to cycles shaders, so I'm going about this a bit blindly.

I've tried mixing a few shaders, and it works in the rendered viewport, but not in the full render.

I'm trying to make spaceship thrusters. It should start emitting brightly, and then gradually fade to transparent. I've tried both particles, and volumes, but neither worked well for me.

This is my material:

Shader program

And here is the (expected) 3D View rendered result (left) and the actual (incorrect) rendered result (right):

Shader output

The .blend file

EDIT: I was able to get it to work by switching to CPU from GPU.

$\endgroup$
  • $\begingroup$ Is it possible you could upload your .blend? $\endgroup$ – gandalf3 Jun 11 '15 at 9:51
  • $\begingroup$ give me a moment and I'll make a simplified blend that exhibits the problem. $\endgroup$ – Neilos Jun 11 '15 at 9:57
  • $\begingroup$ @gandalf3 Interestingly when I tried to create a new blend showing the problem I couldn't reproduce it (it worked). But I cannot get my blend to work so I created a cut down version of my blend and uploaded that (see the link at the top of the post). There is probably some setting I have not set. I canabalised another blend file to create this one so some artifact from that surely remains which is causing the problem. $\endgroup$ – Neilos Jun 11 '15 at 10:23
  • $\begingroup$ On a slight tangent. If I wanted to copy certain objects from my scene to a new blend, what's the easiest way to do this? $\endgroup$ – Neilos Jun 11 '15 at 10:29
  • $\begingroup$ I was able to solve it by setting the render device to CPU instead of GPU, ,shouldn't I be able to render transparency on the surface shader using the GPU? $\endgroup$ – Neilos Jun 11 '15 at 10:52
3
$\begingroup$

The lamp output node is not intended for use with surfaces, as a matter of fact I'm surprised it worked at all in viewport render.

It works fine for me if you replace it with a material output node:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.