2
$\begingroup$

This is probably an easy fix but I can't figure it out. I'm trying to render the audio with my video along with my video and when I play the video on the media player, I can't hear ANY audio. I've been looking at youtube videos but none of the videos have the same version of Blender as I do. Can Blender render both the audio and video at the same time?

$\endgroup$
  • $\begingroup$ Which version of Blender you are using? OS? $\endgroup$ – p2or Jul 3 '15 at 8:58
  • $\begingroup$ it can, but it is important to have the right selection of encondings. @DevTim's answer gives a good choice $\endgroup$ – Ciprian Tomoiagă May 9 '16 at 2:14
1
$\begingroup$

In properties/encoding find "Audio codec:". It should read something other than "none". Make sure it's set to a format that's compatible with what you selected in "Format" and properties/output. This three should make sense when combined. It would help a lot :) if you included in your question information such as:

  • Blender version
  • The content of the sections above (i.e. format of your video and audio)

Here's a similar question: No audio output in rendered video file

$\endgroup$
1
$\begingroup$

As stated already, you need to set an audio codec, also some video formats don't support audio.

A combination that does work is H.264 for the video (selected from the Output panel) and AAC for the audio (selected from the Audio codec dropdown on the Encoding panel).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.