1
$\begingroup$

I have no idea why this is happening, I revised everything I made (all the logic) to make sure nothing was "odd." I have a simple prop ("active"), all it does is the following: if it is true, the object is visible, if it is false, the object is invisible. Works, right? No, it does not work! I have no idea why. It always used to work, but suddenly it stopped. I have another object (weapon) with the exact same logic, and that one works. Can anyone tell me why this possibly is happening? Also, when I start the scene and the object is visible when the property is false, it can be fixed by toggling the prop to false, then back to true. The problem with this is that I need the object to be invisible at the start and not after I toggle the prop on and off till it works.

EDIT: Here is what I think the problem really is: at the very start of the game engine (as soon as I hit "P", it is visible when it is not supposed to be unless I toggle the property a couple of times. In other words, why is it visible at the very start rather than when it is supposed to be?

$\endgroup$
  • $\begingroup$ I have 3 weapons so far, and 2 out of 3 are having this issue. They all basically have the same logic. $\endgroup$ – blackhole Jun 10 '15 at 22:18
  • 3
    $\begingroup$ Once more, can you show the setup with an image or a .blend file? It is hard to guess with nothing provided. $\endgroup$ – Lev Jun 10 '15 at 22:28
  • $\begingroup$ Well, I mean, I have 2 scenes with a very, very complex setup, but at the final product, when I use debug properties enabled, the prop is false, and the object is invisible. $\endgroup$ – blackhole Jun 10 '15 at 22:33
  • $\begingroup$ What did you change when it stopped working? $\endgroup$ – Anson Savage Jun 11 '15 at 3:43
  • $\begingroup$ @Anson Savage I didn't change anything, I simply didnt notice it. What's odd is that it does work when I toggle it back to true then false. $\endgroup$ – blackhole Jun 11 '15 at 5:04
1
$\begingroup$

For anyone that had this issue, I just made our prop "active" set to true by default. I do not know why this is the case, but it is.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.