0
$\begingroup$

I'm trying to do a Space scene on Cycles so i'm using a Star map background as an Enviroment Map, i made the Nodes already, the texture/image shows up on the Preview..but not in the Render, why? It's the last step i need for this render but this is still giving me troubles :/

enter image description here

$\endgroup$
  • $\begingroup$ What is the mix for? $\endgroup$ – VRM Jun 8 '15 at 15:33
  • $\begingroup$ You could try swapping 'Background' shader and 'Mix shader' $\endgroup$ – Faceb Faceb Jun 8 '15 at 15:33
  • 2
    $\begingroup$ Shows up fine on my machine. You need to uncheck "Transparent" under "Film" on the "Render" tab of your "Properties Panel". $\endgroup$ – galingong Jun 8 '15 at 16:39
  • 1
    $\begingroup$ Sorry, but I can't open the .rar file. Could you try Blend-Exchange instead please? $\endgroup$ – PGmath Jun 8 '15 at 16:59
  • 1
    $\begingroup$ Wait, the solution of @galingong worked! :) $\endgroup$ – beavoru Jun 8 '15 at 17:19
2
$\begingroup$

The environment is not showing up in the render because you have Transparent checked in the Film section of the Render property panel. Uncheck that and it will work.

I would also add that if you DO want to composite the foreground and background element, to leave the Transparent box checked. Then you can enable the Environment render pass and combine the foreground and background renders in the compositor.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ If someone answers a question correctly in the comments we usually give them a day or so to put it as an answer so they can get the rep, see this meta post. $\endgroup$ – PGmath Jun 8 '15 at 17:59
  • $\begingroup$ If he wants to post his solution as an official answer, that's fine by me. $\endgroup$ – Todd McIntosh Jun 8 '15 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.