1
$\begingroup$

I have a 3D model of a house and have tried to texture it using textures from ambientcg.com. When applying this roof texture and exporting to .glb for use in WebGL, the roof looks transparent from certain angles. It looks like this when viewed on gltf-viewer:

enter image description here

https://i.imgur.com/SUCPrq8.mp4

The model looks fine in Blender. I have done some googling and suspect it has something to do with the normals or backface culling. I have tried flipping normals in Blender and doing "recalculate outside" to no avail. I would like to learn what is causing this and how I can fix this in the future.

.glb file download (google drive)

$\endgroup$
3
  • $\begingroup$ unfortunately you didn't pack resources before uploading so we cannot "see" your texturing result $\endgroup$
    – Chris
    Commented Jun 19 at 11:22
  • $\begingroup$ @Chris Hmm strange. It showed "Packed 6 files" before saving. I tried doing it again and uploading. I also added the .glb file which most definitely should include the textures. $\endgroup$
    – Axekan
    Commented Jun 19 at 12:27
  • $\begingroup$ Also make sure that your "Blend Mode" (an EEVEE material setting) is set to OPAQUE, not alpha blend. If you enable alpha blending before export, many WebGL frameworks will have difficulty with Z-ordering like this. $\endgroup$
    – emackey
    Commented Jun 19 at 14:39

1 Answer 1

1
$\begingroup$

ok, in your first uploaded file, you didn't have that problem, but now you have a face orientation problem:

enter image description here

If you click on "face orientation" in the "show overlays" popup, you will get these red faces which will cause shading issues.

enter image description here

So select all objects, go to edit mode, press Shift-N and then it should be all blue again. Try exporting that afterwards. Hopefully it works. Good luck.

$\endgroup$
2
  • 1
    $\begingroup$ Pro tip: In your preferences under Themes > 3D Viewport > Face Orientation Front; set the alpha of that color to zero. Then you can leave Face Orientation checked all the time and it will only show when you have backfaces exposed. $\endgroup$
    – Jakemoyo
    Commented Jun 19 at 16:18
  • 1
    $\begingroup$ nice! didn't know that! thx! $\endgroup$
    – Chris
    Commented Jun 20 at 6:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .