2
$\begingroup$

I am trying to render a Minecraft scene generated by Mineways. Quite simply, some of the blocks seem to have transparent edges, as in some cases the "sky" colour (plain blue for now) is showing through while in other areas there are visible "seams" between the blocks, implying that the adjacent blocks are showing through.

In the picture below this issue is most noticeable around the base of the tree in the foreground to the right and along the bank behind the tree (where the blue sky is showing through) and on the logs at the front of the greenhouse (where there are visible "lines" between the log blocks which seem to be caused by the same issue as these lines go away if I turn off the texture's alpha channel). (Don't worry about the weird lighting/shadows - I'm trying to light the scene from inside the greenhouse but have not finished setting up the lighting yet.) screenshot

EDIT: Here is the .blend file (ultimately this will be the background for another scene, hence the name background.blend). I would appreciate it if, if you make any changes, you let me know what they are instead of just uploading a modified file.

https://drive.google.com/file/d/0Bzg8zit7X1NALWtPM0RUN0tPdU0/view?usp=sharing

EDIT 2: Here is a .zip file containing both the .blend file and the accompanying texture files. Note that the .blend file in this archive is slightly different to the .blend file above as I had to change the textures to use the correct file path to work when the .zip file is extracted.

https://drive.google.com/file/d/0Bzg8zit7X1NANzN3cGIyUl9tSFk/view?usp=sharing

$\endgroup$
  • $\begingroup$ While I don't know what is causing this, I do think I should tell you something. My computer thinks Mineways has a virus. It could be wrong. It is most likely right. I suggest you stop using Mineways all together. But... but now you can't export and import Minecraft terrain! Well, I do have an alternative. After you get rid of Mineways, (Which I highly suggest you do for the sake of your computer), check out this tutorial. It will introduce an alternative service to use instead of Mineways, and will tell you how to render your scene in Cycles. $\endgroup$ – TheMinecraftMan757 Jun 6 '15 at 15:12
  • $\begingroup$ This may actually help your problem in the first place. I suggest to always get rid of software if you know if there is a virus. I know this is really the long way around, but if it has a virus, then it will be a great help to find an alternative. This external software that the video will introduce is actually more flexible. You can even render using resource packs. I hope you find this useful for the safety of your computer system. $\endgroup$ – TheMinecraftMan757 Jun 6 '15 at 15:13
  • $\begingroup$ @TheMinecraftMan757 I've used mineways before in wine, and nothing bad happened.. Though that's not to say that something couldn't have infected it since I tried it. $\endgroup$ – gandalf3 Jun 6 '15 at 16:40
  • $\begingroup$ @Micheal Is it possible you could upload your .blend? $\endgroup$ – gandalf3 Jun 6 '15 at 16:44
  • $\begingroup$ I am sandboxing Mineways in Wine under Linux, so I doubt that even if it is a virus it will do much harm. But the real problem is that the scene is not rendering correctly in Blender. $\endgroup$ – Micheal Johnson Jun 6 '15 at 19:22
0
$\begingroup$

If you look closely, you can see that this is caused texture interpolation getting a little bit of the alpha surrounding the wood texture. So in other words, your wood texture is outlined with a line alpha less than a pixel wide which lets you see through to the objects and sky behind.

enter image description here

This is why you usually want to have a small margin around UVs so interpolation will have something outside with which to interpolate with besides alpha.

To fix this, you can try using the solutions below individually or in combination.

  • Scale the wood UVs in a little so the UVs aren't right up against the alpha:

    enter image description here
    This is really a pretty generous margin for this situation. In this case it only needs to be scaled in about half a pixel, but a little extra can't hurt.

    Not completely ideal, as you lose part of the texture (though it's unlikely anyone would notice).

  • Disable interpolation. It won't completely get rid of the problem, as the texture is still filtered a bit when it's distorted by perspective etc, but it will be so small that it's only visible when viewed really close up. This way you can also save some memory by using the 512x512 texture, as it will no longer be blurred by interpolation if it's disabled.

    enter image description here

$\endgroup$
  • $\begingroup$ I had disabled interpolation and the 512x512 texture is still more blurred than the large version that I included (it is not as blurred as it was before I disabled interpolation but it was still not as crisp as the textures are in Minecraft, but enlarging the texture fixed that). Also I'm not sure that there is alpha around the wood texture, and also the same problem is apparent with the grass blocks behind the tree. $\endgroup$ – Micheal Johnson Jun 7 '15 at 13:10
  • $\begingroup$ @MichealJohnson Did you disable interpolation and set the filter to box and turn the filter size down? $\endgroup$ – gandalf3 Jun 7 '15 at 17:56
  • $\begingroup$ No I did not realise that the filter had any significance if interpolation was turned off. I will check it in a moment. $\endgroup$ – Micheal Johnson Jun 8 '15 at 12:57
  • $\begingroup$ I changed the filter and now not only is the bleeding problem gone but the textures are a lot crisper as well. Thanks! $\endgroup$ – Micheal Johnson Jun 8 '15 at 12:58
  • $\begingroup$ @MichealJohnson As I understand it, since the texture is being transformed and skewed according to the angle of the surface to the camera there is still a need for filtering even if no 2D interpolation is done. This should make the 512x512 texture look good too :) $\endgroup$ – gandalf3 Jun 8 '15 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.