2
$\begingroup$

In blender 4.1 when I use BSDF Node with Transmission weight = 1 the light doesn't pass through the object.

enter image description here

$\endgroup$
1
  • $\begingroup$ oops yes of course $\endgroup$
    – moonboots
    Commented Jun 16 at 13:32

1 Answer 1

4
$\begingroup$

To make Transmission work in EEVEE, you have to enable Refraction in the Render Properties under Screen Space Reflections and also enable Raytrace Refraction in the Material Properties and also give it a value > 0 for Refraction Depth (usually matching the object's size) if you want the IOR to have an effect on the refraction.

By the way, you can leave the Blend Mode at Opaque for this, because it is only needed for Alpha transparency, which is something different than Transmission.

transmission/refraction

$\endgroup$
1
  • 1
    $\begingroup$ Thanks a lot for your quick answer. $\endgroup$ Commented Jun 16 at 14:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .