2
$\begingroup$

I have this flower that I added an armature to to bend the stem and it works fine. But when I use the control bone to bend it to a certain point, it's like the skeleton says that it can't get to that pose. Even though it looks it should be able to, it refuses to.

The Armature:

enter image description here

The control bone(top) and the one with the IK Constraint to make the other bones move when that one moves:

enter image description here

Good bend:

enter image description here

The issue when I move it a little bit more to the side:

enter image description here

The armature:

$\endgroup$
4
  • $\begingroup$ I don't know why it bugs, maybe a calculation problem, that said why do you use such a long chain? you could use only several bones and segment them. $\endgroup$
    – moonboots
    Commented Jun 8 at 12:44
  • $\begingroup$ I wan using less bones, but I wanted to make the mesh look smother when bending so I added more bones, but I'm sure the problem would still be there :( $\endgroup$
    – Soku
    Commented Jun 8 at 12:47
  • $\begingroup$ have you tried to segment your bones? It is made to avoid tens of bones $\endgroup$
    – moonboots
    Commented Jun 8 at 12:50
  • $\begingroup$ Let us continue this discussion in chat. $\endgroup$
    – moonboots
    Commented Jun 8 at 13:00

1 Answer 1

4
$\begingroup$

It may be a problem of calculation, but instead of using tens of bones, maybe just use several and segment them?

First thing create an armature with for example 3 bones, display them as B-Bones (if you want to make them thicker use AltCtrlShiftS in Edit mode), you don't need to display them as B-Bones but it will make the segmentation visible:

enter image description here

Select the 3 bones in Edit mode then in the Bone panel > Bendy Bones > Segments > press AltLMB on the value, type 3 (or whatever segmentation value you want) and Enter:

enter image description here

Switch to Pose mode and enable the Auto IK option:

enter image description here

Select the last bone and move it:

enter image description here

Also you can set the Ease In and Out values to make it rounder:

enter image description here

$\endgroup$
2
  • $\begingroup$ it's much easier? $\endgroup$
    – moonboots
    Commented Jun 8 at 13:12
  • $\begingroup$ I'll try that thanks $\endgroup$
    – Soku
    Commented Jun 8 at 13:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .