0
$\begingroup$

Ok so, whenever I got select the armature first, and then the arm mesh, put it into weight paint and I try to click on the bone, the armature turns gray and the armature goes into object mode or any mode I was previously in. I turned off lock objects mode, I don't have paint mask or Vertex Selection on. Does anyone know why this is happening?

https://i.sstatic.net/rEAjC3Zk.png

$\endgroup$
3
  • $\begingroup$ Sorry, this is a bit confusing. You "had the mesh and the armature in weightpaint mode"... first of all, an armature cannot be in Weight Paint mode, only a mesh object. And you "had" them, but now you are in Edit Mode or what exactly? Which object is in Edit Mode, the mesh or the armature? You cannot edit both at the same time, you can only edit multiple objects if they are of the same type, like two mesh objects, two curve objects or two armature objects. But not a mesh and a curve or a mesh and an armature or not a curve and armature either. $\endgroup$ Commented May 27 at 5:49
  • $\begingroup$ I'm bad at explaining thing, i'm new to blender (I think i had the armature in edit mode) $\endgroup$ Commented May 27 at 7:45
  • $\begingroup$ I repeat what I wrote under your second question: in the screenshot your mesh object is not even parented to the armature. Without parenting this will not work. I strongly recommend you watch tutorials on rigging because, no offense, but it seems you do not reallly know how this works and what you are doing. $\endgroup$ Commented May 27 at 9:48

2 Answers 2

1
$\begingroup$

The reason you can't select any bones is because 2 objects are selected, but the one that is active is not your armature. To fix this, you need to select your armature after selecting the mesh so that it is active.

P.S. The active object has a yellow outline and the selected objects have an orange outline.

$\endgroup$
1
$\begingroup$

Are you sure you want to select the bone in Edit Mode? Or do you want to be able to select a bone and then paint the weight associated with this bone? To do this the armature needs to be in Pose Mode, not Edit Mode and the mesh object in Weight Paint mode.

You can achieve this the following way:

  1. Switch to Object Mode and then first select the armature and then Shift+left-click to select the mesh object next. Now the armature should have an orange outline and the mesh a yellow (well, brighter orange) outline.

    select in object mode

  2. Now switch to Weight Paint mode. This will switch the mesh object into Weight Paint mode while the armature will automatically switch to Pose Mode (not shown in the mode selection field).

    switch to weight paint

  3. With holding Alt while left-clicking on the bone you can select it and the mesh will show the weights assigned to this bone. This way you can Alt+click select bones and then change their weights with painting.

    switch bones

$\endgroup$
3
  • $\begingroup$ file:///C:/Users/olivi/OneDrive/Pictures/Screenshots/Screenshot%20(5).png I followed it and this is what I got, it's the same thing that's been happening and I don't know why. I turned off lock object mode and I turned off Paint mask and vertex selection. Why does the armature keep turning orange! ☹️ $\endgroup$ Commented May 27 at 9:07
  • 1
    $\begingroup$ @Oliviagamble That's a link to a local file on your computer. I cannot look into your computer. Please edit your question and upload the image there. Stupid question: have you correctly parented your mesh to the armature? Does the mesh object has an Armature modifier with the correct armature chosen in the Object field? $\endgroup$ Commented May 27 at 9:15
  • $\begingroup$ The stupid question was the whole reason why weight paint wasn't working properly, this whole time I haven't parented my thing properly. Thank your for the help! $\endgroup$ Commented May 27 at 19:20

Not the answer you're looking for? Browse other questions tagged .