3
$\begingroup$

So, I was trying to make Gojo poses, and when I was about to finish it, light and shadows don't appear on the basemesh itself. When I put another object, it seems to be normal. The basemesh with an object on top

The basemesh with an object below it

The basemesh with no obstruction

Can you fix this?

File (blender exchange website says it exceeds 30 MB but it's only 29.3MB so I uploaded it to Drive.) https://drive.google.com/drive/folders/1yPAbx0en-4zkaGjcVfOyV7U0MxAN4BuX?usp=sharing

$\endgroup$

1 Answer 1

6
$\begingroup$

Have you created the material for the character yourself? I guess not since you do not seem to know what it does. This is a shadeless material, meaning it does not show any shading etc., which is basically achieved by creating an Emission shader.

It does not seem to get any light or shadows, but in fact it is a light itself. You can see this for example that even when you turn all lights and the background in the scene off, the character is still visible:

emissive material

But in EEVEE, emissive materials on meshes do not affect the scene. If you switch to Cycles instead, you can see (I increased the exposure a bit to make it more obvious) that with all lights and background disabled, the character sheds light onto the plane above his head, while in EEVEE there was just a very subtle reflection (which would have completely disappeared if the plane had just a Diffuse BSDF as material):

light bounces

The only solution to this would be to create a "normal" material for the character, but of course this will change the overall look and interaction with the scene.

A very simple way to do this would be to go into the Shader Editor and select the main custom group "FP Anime", then press Tab to edit it as follows: simply go to the very end on the right to the group output and replace the Emission node with a Diffuse BSDF (for example, something that interacts with light). Then press Tab again to leave the node group.

The only thing is that a lot of the calculations inside this group might be unnecessary then, but I'm not gonna go examine this in detail to find where to clean it up or reduce it, esepcially not without knowing what your goal for the materials. Once you changed the custom group, the other materials using the same group should be changed as well.

custom node group

replace emission with diffuse

And this is how it looks like afterwards with the lights and background turned back on again (and the plane above the head removed):

result with diffuse

Another alternative could be, if you want to keep a little bit of the non-realistic emissive shading but also make the material react to light and shadow, use a Principled BSDF node where you can use the color for Base Color and Emission > Color with a lower Strength to have a bit of that emission lighting up the shadow areas.

with principled bsdf

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .