1
$\begingroup$

I'm trying to bevel the center of my object but it is not going the way I want it to. I tried 2 different ways:

  1. I tried with the Mirror modifier but it creates a "w" shape. I want a soft "u" shape.

First Attempt

  1. I tried after applying the mirror modifier. When I try beveling the same corner it doesn't do anything.

Second Attempt

Is there something I am missing?


Edits (Question for @GordonBrinkmann)

BevelAfterMirror

MirrorAfterBevel

$\endgroup$
7
  • $\begingroup$ Maybe activate the Clipping option of the Mirror modifier? $\endgroup$
    – moonboots
    Commented May 23 at 7:56
  • $\begingroup$ @moonboots Unfortunately it does not work like that... the Bevel tool has no "Border" option like the Inset tool for example. Angie, by the way: it looks like in the upper part there is a face on the inside at the mirror axis, I would delete that to avoid getting interior faces. Without the face you cannot bevel that edge, however the center has to be beveled after applying the Mirror modifier anyway I'm afraid. And then the interior face will become a problem when trying to bevel that edge. $\endgroup$ Commented May 23 at 8:17
  • $\begingroup$ @Gordon Brinkmann Actually it's not clear to me what Angie wants ;) $\endgroup$
    – moonboots
    Commented May 23 at 8:19
  • $\begingroup$ @moonboots Sounds to me like doing something like this: bevel center edge but the problem is, the Mirror modifier does not allow that... $\endgroup$ Commented May 23 at 8:34
  • 1
    $\begingroup$ @GordonBrinkmann I'll try both ways :) thanks for the help $\endgroup$
    – SailorDune
    Commented May 24 at 2:54

3 Answers 3

1
$\begingroup$

Temporarily disable the Mirror modifier and then delete these faces marked with red X then try enable mirror again:

enter image description here

$\endgroup$
10
  • $\begingroup$ wow....is Angie Kim another account of you or how could you replicate that geometry in such a short time that perfect!? 😳 $\endgroup$
    – Chris
    Commented May 23 at 8:15
  • 1
    $\begingroup$ @GordonBrinkmann yes I copied their screenshot and painted an X lol. Or maybe I'm just a hacker? haha. I do remember I had a similar problem like this. But when you mirror and apply the modifier it is closed (as in their 2nd attempt). So it should work like here snipboard.io/7R4nAg.jpg $\endgroup$
    – Harry McKenzie
    Commented May 23 at 8:37
  • 1
    $\begingroup$ @harrymckenzie It worked! i deleted the face>> applied the modifier>> and beveled! thank you $\endgroup$
    – SailorDune
    Commented May 23 at 8:37
  • 1
    $\begingroup$ @Chris He's using the screenshot from the question. Harry: I would only point out to Angie, that this solves the problem with beveling the edge after applying the Mirror modifier, but it is still not possible to bevel that edge "from the center" as long as the modifier is still in use. (But you don't have to disable it to delete that face.) //EDIT: Never mind, Angie is happy :D $\endgroup$ Commented May 23 at 8:39
  • 1
    $\begingroup$ @HarryMcKenzie That's my own mesh, not the one from the question. There is no interior face. I was focusing on the procedural part of it because it's applicable to other meshes (even "good" ones) as well, not just that specific one. But since Angie realized from your answer that deleting the faces helped and in my first answer I explicitly mention your answer and that the interior faces should be removed in any case, and I commented it under the question, I just hope we both made this point clear enough. $\endgroup$ Commented May 23 at 16:05
1
$\begingroup$

If you want to do this without applying the Mirror modifier, you need to add an extra supporting edge like this:

supporting edge

You can get it for example by selecting the front and back edge in Edge Select mode and right-clicking, then choose Subdivide (do not use Vertex or Face Select, in this case the the face will be subdivided in X and Y direction).

subdivide

Then you have to place it in front view, it should be the same height as the central edge at the mirror axis to get a rounded curve at the bottom (either use snapping while moving on Z, or select both edges and scale to 0 on Z or just eyeball it). How far to the right is a bit tricky, it depends on how rounded the bevel should be and is maybe a bit try and error:

same height for edges

Now press Ctrl+B to bevel the edge. Press C to enable Clamp Overlap to make sure you do not exceed the central edge to the left, draw the mouse as far as possible. Then confirm the bevel with left-click. At the center there are now duplicate vertices. Press A to select all, then M > Merge > By Distance. The interior faces you should delete in any case as Harry's answer shows.

bevel with clamp overlap

Another possible, even less destructive method would be, to use a Bevel modifier after the Mirror modifier. This takes the new geometry created by the mirror into account.

$\endgroup$
1
$\begingroup$

First of all, before you do anything else: delete faces at the center mirror axis which would become interior faces after mirroring, otherwise they will mess everything up no matter which method you choose.

Here another, fully procedural solution: Create the object with a Mirror modifier without any beveled edges. Instead of beveling them destructively in Edit Mode, I will use the Bevel modifier for it. Therefore I select that edge which should be beveled/rounded the most presumably and under Edge Data set the Bevel Weight to 1, in my example I choose the bottom right edge:

set bevel weight

Now add a Bevel modifier after the Mirror modifier and set the Limit Method to Weight. Set the Segments to a number you want and increase the Amount to value which gives you the amount of roundness on the edge that you want. For my example, I like the edge at the bottom right at a bevel amount of 2 m:

set maximum bevel amount

Afterwards you can select other edges and increase the Bevel Weight to an amount which gives them the roundness you want without overlapping. The good thing is, if you mess this up in one way or another, it is fully procedural and you can edit all values. By default Clamp Overlap is enabled in the Bevel modifier anyway, in this case increasing a bevel weight too much on one edge automatically reduces the bevel weight on another edge to avoid overlapping. And you can also move the base edges in Edit Mode to change the shape of the bevel.

varying bevel weights

$\endgroup$
2
  • $\begingroup$ I tried your procedural method. It seems like the best method for future edits. All the corners worked well except for the ones that are in the center. 1. When I add the bevel modifier after the mirror modifier, the center edges don't get beveled at all. 2. When I add the bevel modifier before the mirror modifier, the center edges get beveled but it does the "pinching" bevel. I'll add the photos in my question for reference! $\endgroup$
    – SailorDune
    Commented May 26 at 7:50
  • $\begingroup$ @SailorDune I guess you have to upload your model then. Because I did nothing special in my answer. Did you check for interior faces and deleted them as my other answer and the one by Harry told you? Because the second with the pinching clearly shows there is a face in the center. As I said in my other answer, this will mess it up. So, delete interior faces, make sure the edges have a bevel weight (the one in cutout does not, it is still black) and make sure there is no duplicate geometry. With these premises it should work, otherwise I need to look at your file where the problem is. $\endgroup$ Commented May 26 at 14:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .