4
$\begingroup$

I am using Linux Mint 17, and I am very happy that I was finally able to get my GPU to render on it. My problem was that I needed to properly run Blender as root. However, when rebooting my computer, I need to run Blender in root again to make the GPU rendering work. This would be fine, except for the fact that everything written to the hard drive by Blender is owned by root, and cannot be edited unless running everything in root.

I've heard that installing nvidia modprobe will allow programs that use CUDA processing without running the program as root. I have tried to install this in a number of ways, and it doesn't appear to be working.

Does anybody have any suggestions? (It's possible that I'm not properly installing modprobe, but I've tried both suggestions on this answer: CUDA rendering on Linux Mint or Ubuntu variants)

$\endgroup$
  • 1
    $\begingroup$ Is this question how to avoid running Blender as root? Or how to change default permissions files that Blender creates? $\endgroup$ – ideasman42 Jun 3 '15 at 4:47
  • $\begingroup$ @ideasman42 Preferably to avoid running Blender as root but still use CUDA processing. $\endgroup$ – Anson Savage Jun 3 '15 at 4:48
  • 1
    $\begingroup$ Oh, and you can do a simple chmod to your files to get rid of the root only access. Basic linux stuff. $\endgroup$ – TARDIS Maker Jun 3 '15 at 4:54
  • 2
    $\begingroup$ Usually running blender as root once is enough, then it can be used as a normal user.. Have you tried using blender has a normal user since running it as root? $\endgroup$ – gandalf3 Jun 3 '15 at 6:15
  • 2
    $\begingroup$ @TARDISMaker Some versions/packages of the Nvidia drivers seemed to have this issue. See some of the links in the answer linked above. $\endgroup$ – gandalf3 Jun 3 '15 at 6:39
1
$\begingroup$

Unfortunately I don't have nvidia/cuda on my system, but I happened to notice information that most likely will solve your problem. See this link first about information how to install nvidia drivers and enable cuda just to check that you're setup is fine. And then have a look this forum post where Nusaman is using blender with out root (forum post #12).

To recap:

  1. make sure that you have latest drivers installed. (Nusaman used: cuda-5.5.22-1 and nvidia-334.21-2, but he's using archlinux)
  2. Start blender or some other cuda program (like cudaminer) as root.
  3. Then close that program (could be that firts render something with blender+cude as root)
  4. Start blender as normal user

What I gathered from multiple sources is that nvidia cuda drivers need to be loaded and for some reason initialison of cuda needs root, but will work with normal user after that.

Please note that you might need extra dkms and dev packages also, to get this working.

$\endgroup$
  • $\begingroup$ @anson savage Just to clarify the down vote. This procedure did not work for you or running and stopping a program with root permissions once before starting blender as a normal user is not an option for you? $\endgroup$ – Manwe Jun 25 '15 at 10:28
-1
$\begingroup$

After having this problem for a second time (when installing ubuntu on my new hard drive) I have found the solution, you must install the package nvidia-modprobe which will detect your nvidia CUDA device and make it available for blender.

Source: Enabling GPU rendering for Cycles?

Also, where are you getting the nvidia drivers from if you install the ones from a ppa it won't work (at least for me) if you go to additional drivers, does the driver you're useing say "proprietary tested"?

$\endgroup$
  • $\begingroup$ I'm running blender 2.74. It's not from the software center, just downloaded from blender.org. $\endgroup$ – Anson Savage Jun 19 '15 at 20:52
  • 4
    $\begingroup$ Did you update your drivers to version 352.21 most drivers from before this one don't work with blender without root permission. When I fixed this problem for my self I updated blender and my nvidia drivers at the same time so I don't know witch one fixed the problem $\endgroup$ – SupaKoopaTroopa64 Jun 19 '15 at 21:00
  • $\begingroup$ Okay, I tried everything you said (installed the new driver, restarted the computer, ran blender, didn't work, ran as root, worked, restarted the computer, ran blender, didn't work). Do you have any other suggestions? Thanks. $\endgroup$ – Anson Savage Jun 22 '15 at 13:26
  • $\begingroup$ maybe it's just a problem with the driver for your specific GPU, or maybe your Linux distro. $\endgroup$ – SupaKoopaTroopa64 Jun 24 '15 at 23:49
  • $\begingroup$ @AnsonSavage Don't restart your computer when you change from root to normal user. $\endgroup$ – Manwe Jun 25 '15 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.