5
$\begingroup$

I'm completely new to Blender so I have no idea how to make this work but I almost made it (I think). I'm trying to make a player model for Garry'a Mod using a model and textures from another game. I have the .obj, .mtl and texture pictures in the same folders. I have edited the .obj s and .mtl s to use the correct files (I think I did it right). When I open the .obj files and put it into texture mode, or whatever it is, I can't see textures on any of them, but when I set it to texture paint I can see the textures on the selected piece. I feel like I'm close, but I don't know how to do it myself.

I also went to the little row of editing things near the top right, added a new texture, and selected the picture file before I did the texture paint (If it makes a difference).

Pictures Of Situation

Fresh from import

Added the texture

In object mode

In texture paint mode

$\endgroup$
  • 1
    $\begingroup$ Add some screenshots if possible, so we can see the problem (it's a visual problem, after all. Welcome to stackexchange. $\endgroup$ – WorldSEnder Jun 2 '15 at 21:35
  • $\begingroup$ Added some pictures. First is right after import, second is the added texture, third is in object mode with textures enabled, last is in texture paint mode. $\endgroup$ – kanderson55 Jun 2 '15 at 23:51
  • $\begingroup$ Please show all your texture panels, even in separate images ... especially [influence]. Please allow your images to show indicators such as Blender Render, Edit Mode [Object, Edit, Texture Paint], Display Mode [Solid Material] $\endgroup$ – atomicbezierslinger Jun 3 '15 at 6:44
  • $\begingroup$ Please show the properties panel in 3D View. Please show a render. Please state whether or not your render is correct. $\endgroup$ – atomicbezierslinger Jun 3 '15 at 7:40
1
$\begingroup$

Not sure it is your problem but usually (in my use case) when you can see a texture in Texture paint and not in Object mode, it is caused by the viewport shading settings.

enter image description here

| improve this answer | |
$\endgroup$
0
$\begingroup$
  • In the 3d View Properties Panel, Shading Panel, Make Sure Mulitexture is set and not GLSL.
  • Make sure your Texture Influence Panel has Color selected TRUE and set to 1.0
  • Know that is quite possible for texture paint window to show a texture while the final render has no effects from the texture because the influence values are not set correctly to achieve your desired results.
  • Since you have stated you are new to Blender, in the not so extreme case, delete all materials, and textures and start fresh.
  • UV unwrap
| improve this answer | |
$\endgroup$
  • $\begingroup$ If using more textures than one and wanting to see their combined influence, then Multitexture is not the way to go here - GLSL is able to show the combined stack of textures. UV Unwrap on a model that is already holding a texture mapping? Bad mistake there, as the image will not match up and then we will see the OP ask for how to get the UVs aligned again. Only the image used as texture should be modified in this case considering OP's experience with blender. $\endgroup$ – Craig D Jones Jul 24 '17 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.