5
$\begingroup$

Currently working through Match Track Blend (version 01) with my shiny newish computer w/16 GB Ram on Windows 7. Have set my Sequencer / Clip Editor Memory Cache Limit to 8192.A

On rendering the first lesson (this one - https://www.youtube.com/watch?v=w3E3zRQSpcI - as found on my DVD), I found that upon playing the output .avi in VLC, the audio in the .avi file was out of sync with the video.

(I'm aware of the AV-Sync feature in the VSE, but this is a feature to help the editor while in the VSE and should have no bearing on the final .avi file)

Investigating, I found that when importing the original footage (from DVD, file 'tracking_intro.mov', with Render Properties Frame Rate set to 25FPS) and then exporting as HDTV 720p at 25FPS, the resulting render (with no changes to content) has the audio rushing the video by about half a second.

The audio and video strips perfectly match each other's position in the VSE. Everything indicates that it should output a video roughly equivalent to the video it imported.

In short, what in hell? Does anybody have a solution? Really wanted to get into some video editing, but it seems pointless unless I can solve this audio problem.

The source file is tracking_intro.mov from the Match Track Blend DVD.

My blender settings before clicking 'render animation'

--Rev

PS: Had this problem years ago when I first got the DVD, but figured the problem was down to my hardware. Now I know there has to be some settings somewhere that'll solve this issue...

==== EDIT ====

Have since experimented with time stamps and image tracks. The image tracks seem to work just perfectly - outputting a video file perfectly in sync with the audio. However, in examining the video file in VSE, I've discovered that the original video track appears to have several frames at the start of the video which do not show up in the VLC file, nor in the exported image files, nor in the reimported image track.

In these frames, Sebastien raises his head and opens his eyes before he begins to speak. In addition, VLC's statistics for the file seem to show some lost frames...

Lost frames?

I'm not looking for any trouble here - I'm just trying to understand the situation for my own satisfaction. As pointed out below, Sebastian suggests that we work with image files, which makes sense. But in case I encounter this problem again - is this a case of a slightly borked file?

Many thanks to all who've looked in at this!

--Rev

$\endgroup$
  • $\begingroup$ Have you tried to convert the movie source file into an images sequence? At the very beggining of the tutorial, he tells us that it may be problematic to work directly with the .mov file, depending on the FFMPEG version in use. Next, what setting have you set up in the User Preferences > System tab for the Audio Output Device? You should try another. And finally, try some alternative codecs for the output of your render, it may solve the problem. $\endgroup$ – Polosson Jun 3 '15 at 13:33
  • $\begingroup$ The image sequence 'solves' my problem, in that I can output a file with the audio and video in sync! Many thanks! Now I'm just trying to track down why I seem to have extra frames hidden away in the file... see above...! =) I'll look into the Audio Output Device... $\endgroup$ – Reverend Speed Jun 18 '15 at 19:17
  • $\begingroup$ Polosson, ultimately going to mark this problem down to 'who the hell knows' - but your point about converting the video track into an image sequence seems to 'fix' the issue (even though there are lingering questions!). I'd be happy to mark this as 'correct' if you posted your response as an answer. $\endgroup$ – Reverend Speed Jun 19 '15 at 15:02
3
$\begingroup$

At the very beggining of the tutorial, he tells us that it may be problematic to work directly with the .mov file, depending on the FFMPEG version in use within your system.

So you should try to convert the movie source file into an images sequence, and import it in VSE. Then, import the audio of the the original .mov file, and sync it with the images sequence strip.

$\endgroup$
  • $\begingroup$ Done and done. =) $\endgroup$ – Reverend Speed Jun 21 '15 at 9:25
2
$\begingroup$

Try the AV sync button, in the header of the timeline

enter image description here

$\endgroup$
  • $\begingroup$ Thank you, Josh! Unfortunately I think I was somewhat unclear about my issue in my initial question. My problem was that when I played back the output .avi in VLC, the video and audio was out of sync. I usually use AV-sync when using the VSE - just forgot to add it in the example image! Will edit original question to clarify this issue. $\endgroup$ – Reverend Speed Jun 3 '15 at 10:45
2
$\begingroup$

Audio sync issues in playback are often caused by mismatched sampling frequency rates on the audio track.

If for instance you imported a 44.1kHz track, but your video export settings had the audio settings at 48kHz it could cause a change in duration of the audio track, thereby causing sync issues.

I would check the sampling rate of the external audio file, check it in the VSE, and the check it in the output video file, to see if there are any discrepancies.

$\endgroup$
  • $\begingroup$ 44.1 kHz, 48 kHz! ;) $\endgroup$ – josh sanfelici Jun 4 '15 at 6:56
  • $\begingroup$ Sorry about delay in responding, been busy here. Files import at 44.1kHz, scenes are encoded at a rate of 44100 and all files which have been exported report in VLC to be at 44.1kHz. $\endgroup$ – Reverend Speed Jun 18 '15 at 19:06
  • $\begingroup$ Oops, sorry, also 44.1kHz in the User Preferences. Many thanks for looking at this! $\endgroup$ – Reverend Speed Jun 18 '15 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.