I'm trying to render out some view layers to put into the compositor. Most of them rendered perfectly fine, however the one called 'ocean' renders gray nothing, despite the presence of lights and the fact that all of the relevant objects are visible in the render (if I turn on visibility for 'ocean swell' and 'oceandetail' those objects do end up visible in the resulting render but they're not the ones I actually WANT in the render. For reference I followed this tutorial to model the ocean but I did alter some of the settings for my own purposes). Also, weirdly, while it's going about its business rendering nothing, it still stops in the middle citing that it's out of GPU memory about 75% of the time (I've reduced subdivisions, lowered tile and sample size, checked that persistent data is off, restarted the computer and program, etc. but the chance of it running out of memory is not consistent with or without any of those settings).

Here's how it looks in the viewport: enter image description here

And here's what it looks like while rendering: enter image description here

I have tried the most obvious troubleshooting methods to the best of my ability, including:

  • adjusting the view layer settings ('use for rendering' is checked and I have tried to render it with 'render single layer' both checked and unchecked; both produce the same result of Undesired Gray Rectangle)
  • ensuring that the visibility settings in the object tab are correct ('show in renders' is checked)
  • double-checking my node setup (see image below)

enter image description here

Unfortunately I can't share my full project file because it's part of a commission and the client has asked me not to share it, but [EDIT:I'm attaching the file with only the ocean object so you can see my settings.] I'm willing to answer any questions in as detailed a manner as possible, and share screenshots of any of my settings.

Here is the file.

EDIT: the render window now doesn't even do anything, it just shows up as if I've hit F11 to see the render result, but there's nothing there. If I try to do literally anything on this screen or even close out of it, blender crashes. Helpppp

  • 1
    $\begingroup$ You don't necessarily have to share the exact client file; just generating a simple reproducible setup file for sharing via blend-exchange would suffice. Without accompanying sample files or clear reproducible steps, addressing your issue becomes difficult if not impossible. Without such details, we will have to close your question for lack of details. $\endgroup$
    – Harry McKenzie
    Commented May 16 at 2:18
  • $\begingroup$ @HarryMcKenzie Okay, I added it. Let me know if it requires any other changes or things included. $\endgroup$
    – Marten
    Commented May 16 at 13:14

1 Answer 1


When I opened up your project file and hit render my system started working overtime. Then I noticed that you have set your resolution to render 4k at 200%.

I lowered this and the render worked fine for me:

enter image description here

enter image description here

Maybe your computer doesn't want to render at 8K. Have you tried lowering the resolution and seeing if it works?

  • $\begingroup$ I can't believe I didn't catch that, thank you so much. $\endgroup$
    – Marten
    Commented May 16 at 18:11
  • $\begingroup$ My pleasure, good luck with your project ;) $\endgroup$ Commented May 17 at 17:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .