0
$\begingroup$

The letter Q gets inverted when I write with blender. I think I'm doing the right thing. First create text. Puts gemoetry on the text. Conventions text to mesh. Clicks on the object the text should be on and selects the modifier Boolean. All text will be correct without the letter Q. Tested rewrite, import export object.

Q get opposite effect Normals

$\endgroup$
7
  • 2
    $\begingroup$ It's hard to tell what's causing this, maybe the normals are facing the wrong way. Please share a .blend file or provide more details. $\endgroup$
    – KISKAart
    May 15 at 13:50
  • $\begingroup$ It Is probably just boolean error ... It Is too complicated for such operation ... It Is more Common to use a normal or bump texture for such effect ... Or microdisplacement for really detailed shoot. $\endgroup$
    – vklidu
    May 15 at 14:02
  • 1
    $\begingroup$ I would also check if normals are facing the wrong way as @KISKAart suggested. It looks like you are using the default Blender font, I wrote the same text down, converted it into a mesh and it works correctly. Have to set the modifier's Solver to Fast or Exact? Is the issue in both settings? Not only check the normals of your text but also the object with the Boolean modifier on. If that does not help, please upload your file at blend-exchange.com and follow the instructions there to edit the file into your question. $\endgroup$ May 15 at 14:09
  • 2
    $\begingroup$ Another issue could be that after converting the text to a mesh object, the top and bottom faces are not merged with the side faces, i.e. you have open meshes there. This can cause problems with the Boolean modifier as well. Select all the text in Edit Mode and do M > Merge > By Distance. $\endgroup$ May 15 at 14:13
  • 1
    $\begingroup$ Oh, and just a tip... I do not know how the geometry of your object looks like where you want to engrave your text into, but if it is just a simple plain big face, the resulting geometry might be very messy and chaotic. To get a slightly better result and maybe even make the Boolean modifier work better, it is sometimes helpful to pre-cut the face with supporting edges, in this example I made 13 cuts, one for each line of text: plain face vs. pre-cut faces $\endgroup$ May 15 at 14:37

1 Answer 1

0
$\begingroup$

(Using Blender 3.6.8)

It seems that there are some issues with the cut mesh at the part shown in red in the following picture, at the bottom of the letter Q:

Q letter

It requires to activate Solver Options / Hole Tolerant in the Boolean modifier.

Next pictures are a zoom "inside" the mesh of letter Q showing an extra face protruding the wrong side:

Inside Q Inside wireframe


The issue is coming from the curve of letter Q and it can not be solved before it is converted to a mesh. The mesh of letter Q can be edited to merge the two nodes (2 at the bottom and 2 at the top of each Q letter) as follows to remove the wrong face:

Solved

The Hole Tolerant option is not required after this modification.

$\endgroup$
1
  • $\begingroup$ Yay, it work. Have try to fix it for 4 hours. Thanks :D $\endgroup$ May 15 at 19:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .