0
$\begingroup$

I got to 3D model a simple box product, but I'm stuck on doing the corner bevel.

enter image description here

I almost got the result I was expecting, except for this normal issue there, as you can see. I tried to edit the Shade Smooth Angle, tried Normal Edit, but couldn't get it.

enter image description here

Then I tought, maybe I should combine with a Subdivision modifier. So, I got this result:

enter image description here

As you guys can see, I'm stuck in a simple bevelling operation. I can't get a satisfying result.

When using only the Bevel Modifier, if I uncheck "Loop Slide" then I get a nice result on some corners and a poor result on others:

enter image description here

Do you guys have any tip/trick to share?

$\endgroup$
7
  • $\begingroup$ Have you checked for duplicate vertices and/or inverted face normals? Because it looks as if the mesh is messed up there. $\endgroup$ May 15 at 13:39
  • $\begingroup$ @GordonBrinkmann, yes. I tried to merge vertices by distance and also tried to Recalculate Normals in the whole base mesh. $\endgroup$ May 15 at 13:43
  • $\begingroup$ @GordonBrinkmann for Jesus sake. I tried to recalculate normals to Inside and it fixed the issue with the bevel modifier. $\endgroup$ May 15 at 13:45
  • $\begingroup$ But still, I don't understand why I get that weird result when using the bevel modifier plus a Subdivision modifier. $\endgroup$ May 15 at 13:46
  • $\begingroup$ But "Inside" would usually mean the face normals are now pointing inward... which can bring problems with materials later. I actually believe you just cured the symptoms, but not the cause. How did you smooth the object, with Shade Smooth or Shade Smooth by Angle? And why are the bottom edges marked as crease when you have no Subdivision Surface modifier on the object in the screenshot? Because it doesn't do anything for the Bevel modifier. And is there a specific reason for the central horizontal edge? Does the bevel reach all the way down to it? $\endgroup$ May 15 at 13:51

1 Answer 1

0
$\begingroup$

Well, seems like I found something interesting.

After texting with @GordonBrinkmann above, a did the following steps.

  1. Recalculate Normals (Inside Checked). This made the shading look correct, while using the Bevel Modifier.
  2. But, as mentioned by @GordonBrinkmann, with the normals pointing inwards, I could face some problems with materials. Then, I have applied the Bevel modifier to the mesh.
  3. After apply the modifier, I've recalculated the normals, so they got pointing outwards like it should be.

I believe this could be some minor bug in the Bevel Modifier. It's the only thing I can think off. I've been on trial tweeking settings for some hours, until I could find this workaround.

Apply the bevel modifier was not a problem for me, because I was going to do some destructive modelling anyway, afterwards.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .