2
$\begingroup$

I'm trying to finish cleaning up my imported STL from SolidWorks. But the last few Delete -> Dissolve Edges keeps distorting the geometry. This was the original import enter image description here

I used a combo of Delete -> Dissolve Edges, Dissolve Vertices, Limited Dissolve to get to this point enter image description here

But now trying to delete -> dissolve edges on some of these last edges, complete changes the geometry. Please let me know how I can finish cleaning up the extra edges without distorting the geometry or loosing faces. Thank you kindly.

Image shows the before and after when using Delete -> Dissolve Edges enter image description here

Video clip showing the Dissolve Edges not working as I was hoping for

SolidWorks Settings for my STL. Is there anything I should tweak here? enter image description here

Second video showing the problem I'm having with the (F) command Vertex-> New Edge/Face from vertices. Second Video

Face Orientation toggled ON enter code here

$\endgroup$

1 Answer 1

3
$\begingroup$

You could select all these faces and simply press F (Fill):

enter image description here

$\endgroup$
5
  • $\begingroup$ @persyst And if that doesn't work for some reason, you should also check for duplicate or somewhat messed up geometry and especially inverted normals. Because usually I would expect the step in this answer to be unnecessary when you have used Limited Dissolve before. But of course it also depends on the settings you have used for dissolving. $\endgroup$ Commented May 14 at 15:04
  • $\begingroup$ Yes you're right, Limited Dissolve should work $\endgroup$
    – moonboots
    Commented May 14 at 15:10
  • $\begingroup$ Hi thanks for the reply. I reimported my STL and set the Mesh ->Clean up -> Limited Dissolve to have an angle of 0.1. It seemed to give me a cleaner starting point then before. But when I try to use the Vertex ->New edge/face from vertices (F), it seems to combine them in a strange way as shown in the video link below: I posted my SolidWorks STL output settings and the follow up video in my original post also now, showing the problem I'm having with "Fill" (F)? Is there anything else I would need to tweak here? Thanks again. $\endgroup$
    – persyst
    Commented May 14 at 17:03
  • $\begingroup$ @persyst One problem I see there are the holes. Faces cannot have holes without connecting edges, i.e. a hole always has to created by at least two faces. That's why some of the edges remain. Another reason might still be incorrect face normals, but that's not visible in the video. You should enable Overlays > Face Orientation. $\endgroup$ Commented May 14 at 17:36
  • $\begingroup$ @GordonBrinkmann. ah ok so maybe the amount of cleanup I did would be the maximum with the cutouts? My goal was to just clean it up/merge where possible so that the geometry did not look unnecessarily crazy or heavy for rendering a folding animation. So maybe this is good enough? I've placed an image with Face Orientation toggled On. It shows up all blue except like in the above screenshot, but when I tried deleting/dissolving one of the remaining edges, I did notice a pink area. I wanted to upload the one with the pink area showing, but I couldn't reacreate the problem. Thank for your help. $\endgroup$
    – persyst
    Commented May 14 at 17:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .