0
$\begingroup$

I'm trying to make a procedural Lego brick generator and I have gotten it to work for the most part. The last step in the process is to apply a bevel modifier to the brick to round the edges, unfortunately it does nothing unless I uncheck the "clamp overlap" option. After applying the geonodes modifier

I think it's due to en error of the mesh boolean node. As you can see in the first picture some faces of the cylinder aren't properly cut out by the brick (support beam). So one side gets beveled as I intended but not the other one due to the fact that it's not connected to the cylinder.

Anyone knows how to fix this ?

Thank you in advance

enter image description here enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ The fact that it only works when Clamp Overlap is turned off means it's probably duplicated verts or extremely small edges. see what the model looks like with all mods applied except the bevel. You could also try adding a "Merge by Distance" node at the end of your node tree. Clamp overlap just means that if any bevel would push the generated geo past an existing edge it will stop it there. $\endgroup$
    – Jakemoyo
    Commented May 14 at 17:06

0

You must log in to answer this question.

Browse other questions tagged .